summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/baikal/Manifest1
-rw-r--r--www-apps/baikal/baikal-0.6.1.ebuild57
-rw-r--r--www-apps/baikal/files/postinstall-en.txt5
-rw-r--r--www-apps/cgit/cgit-9999.ebuild80
-rw-r--r--www-apps/cgit/files/cgitrc126
-rw-r--r--www-apps/cgit/files/postinstall-en.txt45
6 files changed, 63 insertions, 251 deletions
diff --git a/www-apps/baikal/Manifest b/www-apps/baikal/Manifest
new file mode 100644
index 0000000..55f90f9
--- /dev/null
+++ b/www-apps/baikal/Manifest
@@ -0,0 +1 @@
+DIST baikal-0.6.1.zip 3437686 BLAKE2B f28d3a63166a73571116759df3662c2b19c2eeeebcd7070574dfc3ee8cb046f2d94fdbc4701669291c1bb2cb2b9b92665726127c852c5457cd285f6ffbcc9b00 SHA512 d88ed9fbe1f934d52fd798165675b90972c47c9e138de61e17a14777590ebad5006c1a414a4e0119eb8fa718e01f2aadb6e1d180e23a51fb33e1b5a3539c9e38
diff --git a/www-apps/baikal/baikal-0.6.1.ebuild b/www-apps/baikal/baikal-0.6.1.ebuild
new file mode 100644
index 0000000..7984fe2
--- /dev/null
+++ b/www-apps/baikal/baikal-0.6.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit webapp
+
+DESCRIPTION="Lightweight CalDAV+CardDAV server"
+HOMEPAGE="http://sabre.io/baikal/"
+SRC_URI="https://github.com/sabre-io/Baikal/releases/download/${PV}/${P}.zip"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~ppc64"
+IUSE="+mysql sqlite"
+REQUIRED_USE="|| ( mysql sqlite )"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=dev-lang/php-6[ctype,filter,json,pdo,session,xml,xmlreader,xmlwriter,mysql?,sqlite?]
+ mysql? ( virtual/mysql )
+ sqlite? ( dev-db/sqlite )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc *.md || die "dodoc failed"
+
+ einfo "Installing web files"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r html/* html/.htaccess Core vendor || die "doins failed"
+
+ einfo "Setting up container for configuration"
+ insinto /etc/${PN}
+
+ einfo "Fixing symlinks"
+ local link target
+ find "${D}${MY_HTDOCSDIR}" -type l | while read link ; do
+ target=$(readlink "${link}")
+ target=${target/..\/Core/Core}
+ rm "${link}" && ln -s "${target}" "${link}"
+ done
+ dosym /etc/${PN} "${MY_HTDOCSDIR}"/Specific
+ dosym . "${MY_HTDOCSDIR}"/html
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+ webapp_src_install
+
+ if has_version www-servers/apache ; then
+ fowners -R apache:apache /etc/${PN}
+ elif has_version www-servers/nginx ; then
+ fowners -R nginx:nginx /etc/${PN}
+ else
+ einfo "/etc/${PN} must be owned by the webserver user for baikal"
+ fi
+}
diff --git a/www-apps/baikal/files/postinstall-en.txt b/www-apps/baikal/files/postinstall-en.txt
new file mode 100644
index 0000000..e6a1127
--- /dev/null
+++ b/www-apps/baikal/files/postinstall-en.txt
@@ -0,0 +1,5 @@
+In order to setup baikal:
+- create /etc/${PN}/ENABLE_INSTALL owner apache:apache
+- point your browser at the instal's URL and follow the setup
+To upgrade baikal, you have to follow the setup instructions
+If you're upgrading from 0.2.7, see http://sabre.io/baikal/upgrade/
diff --git a/www-apps/cgit/cgit-9999.ebuild b/www-apps/cgit/cgit-9999.ebuild
deleted file mode 100644
index c312128..0000000
--- a/www-apps/cgit/cgit-9999.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/cgit/cgit-9999.ebuild,v 1.5 2012/06/01 04:30:38 zmedico Exp $
-
-EAPI="4"
-
-WEBAPP_MANUAL_SLOT="yes"
-
-inherit webapp multilib user git-2
-
-[[ -z "${CGIT_CACHEDIR}" ]] && CGIT_CACHEDIR="/var/cache/${PN}/"
-
-GIT_V="1.7.4"
-
-DESCRIPTION="a fast web-interface for git repositories"
-HOMEPAGE="http://hjemli.net/git/cgit/about/"
-SRC_URI=""
-EGIT_REPO_URI="git://git.necoro.eu/others/${PN}"
-EGIT_BRANCH="necoro"
-EGIT_HAS_SUBMODULES="yes"
-EGIT_PRUNE="yes"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc highlight"
-
-RDEPEND="
- dev-vcs/git
- sys-libs/zlib
- dev-libs/openssl
- virtual/httpd-cgi
- highlight? ( app-text/highlight )
-"
-# ebuilds without WEBAPP_MANUAL_SLOT="yes" are broken
-DEPEND="${RDEPEND}
- !<www-apps/cgit-0.8.3.3
- doc? ( app-text/docbook-xsl-stylesheets
- >=app-text/asciidoc-8.5.1 )
-"
-
-pkg_setup() {
- webapp_pkg_setup
- enewuser "${PN}"
-}
-
-src_compile() {
- emake
- use doc && emake doc-man
-}
-
-src_install() {
- webapp_src_preinst
-
- emake \
- prefix="${EPREFIX}"/usr \
- libdir="${EPREFIX}"/usr/$(get_libdir) \
- CGIT_SCRIPT_PATH="${MY_CGIBINDIR}" \
- CGIT_DATA_PATH="${MY_HTDOCSDIR}" \
- DESTDIR="${D}" install
-
- insinto /etc
- doins "${FILESDIR}"/cgitrc
-
- dodoc README
- use doc && doman cgitrc.5
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- webapp_src_install
-
- keepdir "${CGIT_CACHEDIR}"
- #fowners ${PN}:${PN} "${CGIT_CACHEDIR}"
- #fperms 700 "${CGIT_CACHEDIR}"
-}
-
-pkg_postinst() {
- webapp_pkg_postinst
- ewarn "If you intend to run cgit using web server's user"
- ewarn "you should change ${CGIT_CACHEDIR} permissions."
-}
diff --git a/www-apps/cgit/files/cgitrc b/www-apps/cgit/files/cgitrc
deleted file mode 100644
index a3eba11..0000000
--- a/www-apps/cgit/files/cgitrc
+++ /dev/null
@@ -1,126 +0,0 @@
-# Enable caching of up to 1000 output entriess
-#cache-size=1000
-
-
-# Specify some default clone prefixes
-#clone-prefix=git://foobar.com ssh://foobar.com/pub/git http://foobar.com/git
-
-# Specify the css url
-#css=/css/cgit.css
-
-
-# Show extra links for each repository on the index page
-#enable-index-links=1
-
-
-# Enable ASCII art commit history graph on the log pages
-#enable-commit-graph=1
-
-
-# Show number of affected files per commit on the log pages
-#enable-log-filecount=1
-
-
-# Show number of added/removed lines per commit on the log pages
-#enable-log-linecount=1
-
-
-# Add a cgit favicon
-#favicon=/favicon.ico
-
-
-# Use a custom logo
-#logo=/img/mylogo.png
-
-
-# Enable statistics per week, month and quarter
-#max-stats=quarter
-
-
-# Set the title and heading of the repository index page
-#root-title=foobar.com git repositories
-
-
-# Set a subheading for the repository index page
-#root-desc=tracking the foobar development
-
-
-# Include some more info about foobar.com on the index page
-#root-readme=/var/www/htdocs/about.html
-
-
-# Allow download of tar.gz, tar.bz2 and zip-files
-#snapshots=tar.gz tar.bz2 zip
-
-
-##
-## List of common mimetypes
-##
-
-#mimetype.gif=image/gif
-#mimetype.html=text/html
-#mimetype.jpg=image/jpeg
-#mimetype.jpeg=image/jpeg
-#mimetype.pdf=application/pdf
-#mimetype.png=image/png
-#mimetype.svg=image/svg+xml
-
-
-##
-## List of repositories.
-## PS: Any repositories listed when section is unset will not be
-## displayed under a section heading
-## PPS: This list could be kept in a different file (e.g. '/etc/cgitrepos')
-## and included like this:
-## include=/etc/cgitrepos
-##
-
-
-#repo.url=foo
-#repo.path=/pub/git/foo.git
-#repo.desc=the master foo repository
-#repo.owner=fooman@foobar.com
-#repo.readme=info/web/about.html
-
-
-#repo.url=bar
-#repo.path=/pub/git/bar.git
-#repo.desc=the bars for your foo
-#repo.owner=barman@foobar.com
-#repo.readme=info/web/about.html
-
-
-# The next repositories will be displayed under the 'extras' heading
-#section=extras
-
-
-#repo.url=baz
-#repo.path=/pub/git/baz.git
-#repo.desc=a set of extensions for bar users
-
-#repo.url=wiz
-#repo.path=/pub/git/wiz.git
-#repo.desc=the wizard of foo
-
-
-# Add some mirrored repositories
-#section=mirrors
-
-
-#repo.url=git
-#repo.path=/pub/git/git.git
-#repo.desc=the dscm
-
-
-#repo.url=linux
-#repo.path=/pub/git/linux.git
-#repo.desc=the kernel
-
-# Disable adhoc downloads of this repo
-#repo.snapshots=0
-
-# Disable line-counts for this repo
-#repo.enable-log-linecount=0
-
-# Restrict the max statistics period for this repo
-#repo.max-stats=month
diff --git a/www-apps/cgit/files/postinstall-en.txt b/www-apps/cgit/files/postinstall-en.txt
deleted file mode 100644
index b164123..0000000
--- a/www-apps/cgit/files/postinstall-en.txt
+++ /dev/null
@@ -1,45 +0,0 @@
-There is a few variants of configuration:
-1) Via global config file: /etc/cgitrc
-2) Or via local config file, shipped in ./conf dir into webapp_dir. It has to
- be explicitly specified with CGIT_CONFIG env variable in your web server
- configuration.
-
-If you would like to update the list of git repositories in cgit automatically,
-you might consider adding something similar to the following as a cronjob:
-
-"${MY_CGIBINDIR}/cgit.cgi --scan-tree=/git/repo-parent-path > /etc/cgit-repos"
-
-Then add "include=/etc/cgit-repos" in /etc/cgitrc. This way it's simpler and
-more convenient. You won't need to update your cgitrc every time you add a new
-repository.
-
-===============================================================================
- Apache HowTo
-===============================================================================
-
-With a default apache vhost config you can now access your repository at
-http://<vhostname>/cgi-bin/cgit.cgi/
-
-If you wish to access your repository starting from the root and don't want
-'cgi-bin/cgit.cgi' to be invisible, 2 things are needed.
-
-In your apache vhost configuration file for your domain, add the following
-rewrite rules to your
-<Directory /var/www/<vhostname>/htdocs> section.
-<snip>
- RewriteEngine On
- # Redirect all non-existant urls to cgit
- RewriteCond %{REQUEST_FILENAME} !-f
- RewriteCond %{REQUEST_FILENAME} !-d
- RewriteRule ^.* /cgi-bin/cgit.cgi/$0 [L,PT]
-
- # Redirect the empty url to cgit
- RewriteRule ^$ /cgi-bin/cgit.cgi/ [L,PT]
-<snip>
-
-To make cgit create the correct URL's internally add to /etc/cgitrc (or your
-local config file)
-Enable virtual-root=/
-
-After these rules, you can now access cgit via http://<vhostname>/ to get the
-listing, and http://<vhostname>/repository to go directly to repository.