summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/pass/pass-9999.ebuild30
-rw-r--r--app-vim/nginx-syntax/nginx-syntax-9999.ebuild6
-rw-r--r--dev-perl/MouseX-NativeTraits/Manifest1
-rw-r--r--dev-perl/MouseX-NativeTraits/MouseX-NativeTraits-1.09.ebuild21
-rw-r--r--dev-perl/X11-XCB/Manifest1
-rw-r--r--dev-perl/X11-XCB/X11-XCB-0.09.ebuild35
-rw-r--r--dev-perl/X11-XCB/files/X11-XCB-0.09-dynamic-linking.patch70
-rw-r--r--dev-perl/X11-XCB/files/X11-XCB-0.09-fix-xcb-includes.patch15
-rw-r--r--dev-perl/XS-Object-Magic/Manifest1
-rw-r--r--dev-perl/XS-Object-Magic/XS-Object-Magic-0.04.ebuild19
-rw-r--r--dev-python/flask-migrate/Manifest1
-rw-r--r--dev-python/flask-migrate/flask-migrate-1.3.0.ebuild34
-rw-r--r--dev-python/pdb-clone/Manifest1
-rw-r--r--dev-python/pdb-clone/pdb-clone-1.10.ebuild23
-rw-r--r--dev-tex/dot2tex/Manifest1
-rw-r--r--dev-tex/dot2tex/dot2tex-2.11.3.ebuild43
-rw-r--r--dev-util/itstool/Manifest1
-rw-r--r--dev-util/itstool/itstool-2.0.6.ebuild26
-rw-r--r--dev-vcs/stgit/Manifest1
-rw-r--r--dev-vcs/stgit/files/stgit-0.16-man-linkfix.patch11
-rw-r--r--dev-vcs/stgit/stgit-0.18.ebuild88
-rw-r--r--media-gfx/simple-scan/Manifest1
-rw-r--r--media-gfx/simple-scan/simple-scan-2.32.0.2.ebuild43
-rw-r--r--net-libs/webkit-gtk/Manifest2
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.4.11-r201.ebuild16
-rw-r--r--net-news/feed2imap/feed2imap-9999.ebuild31
-rw-r--r--perl-gcpan/Crypt-Format/Crypt-Format-0.06.ebuild22
-rw-r--r--perl-gcpan/Crypt-Format/Manifest1
-rw-r--r--perl-gcpan/Crypt-LE/Crypt-LE-0.17.ebuild30
-rw-r--r--perl-gcpan/Crypt-LE/Manifest1
-rw-r--r--perl-gcpan/Crypt-OpenSSL-PKCS10/Crypt-OpenSSL-PKCS10-0.15.ebuild22
-rw-r--r--perl-gcpan/Crypt-OpenSSL-PKCS10/Manifest1
-rw-r--r--perl-gcpan/Crypt-PKCS10/Crypt-PKCS10-1.5.ebuild24
-rw-r--r--perl-gcpan/Crypt-PKCS10/Manifest1
-rw-r--r--www-apps/baikal/Manifest1
-rw-r--r--www-apps/baikal/baikal-0.6.1.ebuild57
-rw-r--r--www-apps/baikal/files/postinstall-en.txt5
-rw-r--r--www-apps/cgit/cgit-9999.ebuild80
-rw-r--r--www-apps/cgit/files/cgitrc126
-rw-r--r--www-apps/cgit/files/postinstall-en.txt45
40 files changed, 177 insertions, 761 deletions
diff --git a/app-admin/pass/pass-9999.ebuild b/app-admin/pass/pass-9999.ebuild
index 3a316d2..9a600c7 100644
--- a/app-admin/pass/pass-9999.ebuild
+++ b/app-admin/pass/pass-9999.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Id$
EAPI=5
-inherit bash-completion-r1 git-2 elisp-common
+inherit bash-completion-r1 git-r3 elisp-common
-DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely using gpg, pwgen, and git"
-HOMEPAGE="http://www.passwordstore.org/"
-EGIT_REPO_URI="git://git.necoro.eu/others/pass.git"
+DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely"
+HOMEPAGE="https://www.passwordstore.org/"
+EGIT_REPO_URI="https://git.necoro.eu/others/pass.git"
EGIT_BRANCH="necoro"
SLOT="0"
@@ -18,7 +17,7 @@ IUSE="+git X zsh-completion fish-completion emacs dmenu importers elibc_Darwin"
RDEPEND="
app-crypt/gnupg
- app-admin/pwgen
+ media-gfx/qrencode
>=app-text/tree-1.7.0
git? ( dev-vcs/git )
X? ( x11-misc/xclip )
@@ -26,11 +25,9 @@ RDEPEND="
zsh-completion? ( app-shells/gentoo-zsh-completions )
fish-completion? ( app-shells/fish )
dmenu? ( x11-misc/dmenu x11-misc/xdotool )
- emacs? ( virtual/emacs )
+ emacs? ( >=app-editors/emacs-23.1:* )
"
-S="${WORKDIR}/password-store-${PV}"
-
src_prepare() {
use elibc_Darwin || return
# use coreutils'
@@ -46,11 +43,14 @@ src_compile() {
}
src_install() {
- use zsh-completion && export FORCE_ZSHCOMP=1
- use fish-completion && export FORCE_FISHCOMP=1
- emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ BASHCOMPDIR="$(get_bashcompdir)" \
+ WITH_BASHCOMP=yes \
+ WITH_ZSHCOMP=$(usex zsh-completion) \
+ WITH_FISHCOMP=$(usex fish-completion)
use dmenu && dobin contrib/dmenu/passmenu
- newbashcomp src/completion/pass.bash-completion pass
if use emacs; then
elisp-install ${PN} contrib/emacs/*.el
elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
@@ -66,7 +66,7 @@ pkg_postinst() {
if use importers; then
einfo "To import passwords from other password managers, you may use the"
einfo "various importer scripts found in:"
- einfo " ${ROOT}usr/share/${PN}/importers/"
+ einfo " ${EROOT%/}/usr/share/${PN}/importers/"
fi
}
diff --git a/app-vim/nginx-syntax/nginx-syntax-9999.ebuild b/app-vim/nginx-syntax/nginx-syntax-9999.ebuild
index 5e4a82f..cead970 100644
--- a/app-vim/nginx-syntax/nginx-syntax-9999.ebuild
+++ b/app-vim/nginx-syntax/nginx-syntax-9999.ebuild
@@ -2,14 +2,14 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-vim/nginx-syntax/nginx-syntax-0.3.2.ebuild,v 1.6 2013/02/18 14:29:10 aballier Exp $
-EAPI="5"
+EAPI="7"
-inherit vim-plugin git-2
+inherit vim-plugin git-r3
DESCRIPTION="vim plugin: Nginx configuration files syntax"
HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1886"
SRC_URI=""
-EGIT_REPO_URI="git://github.com/Necoro/nginx-vim-syntax.git"
+EGIT_REPO_URI="https://github.com/Necoro/nginx-vim-syntax.git"
LICENSE="vim.org"
KEYWORDS="amd64 ppc x86 ~amd64-fbsd"
IUSE=""
diff --git a/dev-perl/MouseX-NativeTraits/Manifest b/dev-perl/MouseX-NativeTraits/Manifest
deleted file mode 100644
index 691da0c..0000000
--- a/dev-perl/MouseX-NativeTraits/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST MouseX-NativeTraits-1.09.tar.gz 50322 SHA256 f8a5bf5a28702dfb13c8093be5c41cab9c5fc1c5d247ab91e22e7dd72764cb5e SHA512 2aad717c7c78c1014f705a85b8bb8cab79febb827aa478a0884bcdd4d8d702a366785bc6104ba115513c234b8ca71cafcbbbc070ba37d6328255fe1f972c3619 WHIRLPOOL 9b78e6529489b00a50c296f81170f3fd5b00ee2dec5b4e4dfd2862f93b267fafd4d2bc245765b383c3f936c5b08cc06dc98d49db42d72d4245da997b3223a420
diff --git a/dev-perl/MouseX-NativeTraits/MouseX-NativeTraits-1.09.ebuild b/dev-perl/MouseX-NativeTraits/MouseX-NativeTraits-1.09.ebuild
deleted file mode 100644
index 833cfdb..0000000
--- a/dev-perl/MouseX-NativeTraits/MouseX-NativeTraits-1.09.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# This ebuild generated by g-cpan 0.16.4
-
-EAPI=5
-
-MODULE_AUTHOR="GFUJI"
-
-inherit perl-module
-
-DESCRIPTION="Extend your attribute interfaces for Mouse"
-
-LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND=">=dev-perl/Mouse-1.40.0"
-DEPEND="${RDEPEND}
- >=dev-perl/Any-Moose-0.180.0
- >=dev-perl/Test-Fatal-0.10.0"
diff --git a/dev-perl/X11-XCB/Manifest b/dev-perl/X11-XCB/Manifest
deleted file mode 100644
index 1fa575a..0000000
--- a/dev-perl/X11-XCB/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST X11-XCB-0.09.tar.gz 702693 SHA256 e365aeb84a1e2fddd05d6c59ee38548356a2db28fa0170b057ac5e661405201f SHA512 bdc36588606527a9c8c6cdd573f04b8cf42734b7cc7f78b5de459c48489a191896718372a3f41a982fa437d270d6d3fed2e59b39b32d8134bbd9bb9649dcdb00 WHIRLPOOL 162476faadb4d4019a5aad8bf32e5c1bcb2aaf4c7c542f63362024aa186814ae7d832abc4b32ef5d13c0e7d64ee81fb4aa0f5e009749324a456728a05a45bffe
diff --git a/dev-perl/X11-XCB/X11-XCB-0.09.ebuild b/dev-perl/X11-XCB/X11-XCB-0.09.ebuild
deleted file mode 100644
index 3ca45f1..0000000
--- a/dev-perl/X11-XCB/X11-XCB-0.09.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MODULE_AUTHOR="MSTPLBG"
-
-inherit eutils perl-module
-
-DESCRIPTION="X11::XCB - perl bindings for libxcb"
-
-LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
-SLOT="0"
-
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="dev-perl/XS-Object-Magic
- dev-perl/extutils-depends
- dev-perl/extutils-pkgconfig
- virtual/perl-ExtUtils-ParseXS
- x11-libs/libxcb"
-
-RDEPEND="dev-perl/Mouse
- dev-perl/MouseX-NativeTraits
- dev-perl/Try-Tiny
- virtual/perl-XSLoader
- x11-libs/libxcb"
-
-src_prepare() {
- epatch "${FILESDIR}/X11-XCB-0.09-dynamic-linking.patch"
- epatch "${FILESDIR}/X11-XCB-0.09-fix-xcb-includes.patch"
-
- perl-module_src_prepare
-}
diff --git a/dev-perl/X11-XCB/files/X11-XCB-0.09-dynamic-linking.patch b/dev-perl/X11-XCB/files/X11-XCB-0.09-dynamic-linking.patch
deleted file mode 100644
index 817d3ee..0000000
--- a/dev-perl/X11-XCB/files/X11-XCB-0.09-dynamic-linking.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-diff --git a/Makefile.PL b/Makefile.PL
-index 6dff406..67f54c4 100644
---- a/Makefile.PL
-+++ b/Makefile.PL
-@@ -63,61 +63,11 @@ use_ppport;
- cc_warnings if $ENV{X11_XCB_CC_WARNINGS};
-
- require ExtUtils::Depends;
-+require ExtUtils::PkgConfig;
-
--cc_include_paths 'bundled-libs/libxcb-1.8.1/src';
--
--# We link the bundled xcb libraries statically so we don’t have to install them
--# on the system (that might not be possible due to missing permissions).
--makemaker_args->{MYEXTLIB} = join(' ', qw(
-- bundled-libs/libxcb-1.8.1/src/.libs/libxcb.a
-- bundled-libs/libxcb-1.8.1/src/.libs/libxcb-xinerama.a
--));
--makemaker_args->{LDLOADLIBS} = '-lXau -lXdmcp';
--
--{
-- package MY;
-- sub postamble {
-- <<'__EOF__';
--$(MYEXTLIB):
-- echo "xcbincludedir=$$(pwd)/bundled-libs/xcb-proto-1.7.1/src" > bundled-libs/xcb-proto.pc
-- echo "pythondir=$$(pwd)/bundled-libs/xcb-proto-1.7.1/" >> bundled-libs/xcb-proto.pc
-- echo "" >> bundled-libs/xcb-proto.pc
-- echo "Name: XCB Proto" >> bundled-libs/xcb-proto.pc
-- echo "Description: X protocol descriptions for XCB" >> bundled-libs/xcb-proto.pc
-- echo "Version: 1.7.1" >> bundled-libs/xcb-proto.pc
-- cd bundled-libs/libxcb-1.8.1/ && PKG_CONFIG_PATH=$$(pwd)/.. ./configure --with-pic --disable-shared \
-- --disable-composite \
-- --disable-damage \
-- --disable-dpms \
-- --disable-dri2 \
-- --disable-glx \
-- --disable-randr \
-- --disable-record \
-- --disable-render \
-- --disable-resource \
-- --disable-screensaver \
-- --disable-shape \
-- --disable-shm \
-- --disable-sync \
-- --disable-xevie \
-- --disable-xfixes \
-- --disable-xfree86-dri \
-- --disable-xinput \
-- --disable-xkb \
-- --disable-xprint \
-- --disable-selinux \
-- --disable-xtest \
-- --disable-xv \
-- --disable-xvmc && $(MAKE)
--
--__EOF__
-- }
--}
--
--if ($Module::Install::AUTHOR or $ENV{X11_XCB_GENERATE}) {
-- require _GenerateMyXS;
-- _GenerateMyXS::generate();
--}
-+makemaker_args->{INC} = ExtUtils::PkgConfig->cflags_only_I('xcb');
-+makemaker_args->{CFLAGS} = ExtUtils::PkgConfig->cflags_only_other('xcb');
-+makemaker_args->{LIBS} = ExtUtils::PkgConfig->libs('xcb');
-
- WriteMakefile(
- ExtUtils::Depends
diff --git a/dev-perl/X11-XCB/files/X11-XCB-0.09-fix-xcb-includes.patch b/dev-perl/X11-XCB/files/X11-XCB-0.09-fix-xcb-includes.patch
deleted file mode 100644
index 9cfdd87..0000000
--- a/dev-perl/X11-XCB/files/X11-XCB-0.09-fix-xcb-includes.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/XCB.xs b/XCB.xs
-index 152a5aa..d3060df 100644
---- a/XCB.xs
-+++ b/XCB.xs
-@@ -1,8 +1,8 @@
- #include "EXTERN.h"
- #include "perl.h"
- #include "XSUB.h"
--#include <xcb.h>
--#include <xinerama.h>
-+#include <xcb/xcb.h>
-+#include <xcb/xinerama.h>
-
- #include "ppport.h"
-
diff --git a/dev-perl/XS-Object-Magic/Manifest b/dev-perl/XS-Object-Magic/Manifest
deleted file mode 100644
index 839273b..0000000
--- a/dev-perl/XS-Object-Magic/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST XS-Object-Magic-0.04.tar.gz 66287 SHA256 3dea54e196d4ca13a5186dbe7b12d067ff4aaafb15f6e62a8bd1010c8f84cf0d SHA512 315288496c0bab79f16d010f7f140dc1483bb3a1053a7fc41a048308aa1f9ae01b03795be28f132c856360176372d2251315ae62db950e377be88ff222a441dd WHIRLPOOL fd96279996f2330a7fac5e4dda3439d08f38437af96b8328b5a000cdab759e04a36affd0500889879b5cc6c1ea04644f7cd7fddc749107ec1b82b19e60dab973
diff --git a/dev-perl/XS-Object-Magic/XS-Object-Magic-0.04.ebuild b/dev-perl/XS-Object-Magic/XS-Object-Magic-0.04.ebuild
deleted file mode 100644
index a74c109..0000000
--- a/dev-perl/XS-Object-Magic/XS-Object-Magic-0.04.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MODULE_AUTHOR="FLORA"
-
-inherit perl-module
-
-DESCRIPTION="Opaque, extensible XS pointer backed objects using C<sv_magic>"
-
-LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="dev-perl/Test-use-ok
- dev-perl/Test-Fatal
- dev-perl/extutils-depends"
diff --git a/dev-python/flask-migrate/Manifest b/dev-python/flask-migrate/Manifest
deleted file mode 100644
index 6aef805..0000000
--- a/dev-python/flask-migrate/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST Flask-Migrate-1.3.0.tar.gz 8400 SHA256 8d142bcae64d45eda6efab821283841380749653e49030aea59f0059071d134a SHA512 dbec7fee9027f9446c57a3d24b171a59dcde1e7023e20efc7eb578f41b7c5228a6704edf2cf7afec5e2fc5f8c37a76abeae5a1b9cf0d95c132e7e834f31f7b14 WHIRLPOOL f8c43f3427cbd6cc72e39cfb4f4329f9e826b2b71ca3310d6831121c5a6c9f7915d3a5308f885cb27ad2d3d77197d411bda026d9636c25bbc122069c41a011f6
diff --git a/dev-python/flask-migrate/flask-migrate-1.3.0.ebuild b/dev-python/flask-migrate/flask-migrate-1.3.0.ebuild
deleted file mode 100644
index 6d9a3bc..0000000
--- a/dev-python/flask-migrate/flask-migrate-1.3.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
-
-inherit distutils-r1
-
-MY_PN="Flask-Migrate"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="SQLAlchemy database migrations for Flask applications using Alembic"
-HOMEPAGE="https://pypi.python.org/pypi/Flask-Admin"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- dev-python/alembic[${PYTHON_USEDEP}]
- dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
- dev-python/flask-script[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- "
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
-}
diff --git a/dev-python/pdb-clone/Manifest b/dev-python/pdb-clone/Manifest
deleted file mode 100644
index 96527aa..0000000
--- a/dev-python/pdb-clone/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST pdb-clone-1.10.tar.gz 93347 SHA256 802c510e6a2f2e65a2ce36e0929d7d9df66ad5b2589bc6e6d69d9a1b875a2b19 SHA512 22b091368750c12e3d766434c5bf21722b99f1dcb3588d6085edb320a6c3f4f35d8297d2b8a90fbd1e9d1abf9858448a45e1fa07e247978da4f42b176d50f460 WHIRLPOOL 6c6a154286b90e09d56978a20e448b916184eca089a5a95dfa997ce5aaa911e5c22c3596f74ee054ec97104224bbc91f00b2122c3aa1606497d878f3109df9d5
diff --git a/dev-python/pdb-clone/pdb-clone-1.10.ebuild b/dev-python/pdb-clone/pdb-clone-1.10.ebuild
deleted file mode 100644
index 0fa7698..0000000
--- a/dev-python/pdb-clone/pdb-clone-1.10.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="A clone of pdb, the standard library python debugger."
-HOMEPAGE="https://code.google.com/p/pdb-clone/ https://pypi.python.org/pypi/pdb-clone"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="!<app-vim/pyclewn-2.0.0"
-RDEPEND="${DEPEND}"
-
-DOCS=( README{,.rst} NEWS pdb-clone.wiki/ )
diff --git a/dev-tex/dot2tex/Manifest b/dev-tex/dot2tex/Manifest
new file mode 100644
index 0000000..3e2b883
--- /dev/null
+++ b/dev-tex/dot2tex/Manifest
@@ -0,0 +1 @@
+DIST dot2tex-2.11.3.tar.gz 664750 BLAKE2B 9c7effeca0d71810ce37e126df9e7df2b9df19be41393916c85e49df0dc116f42e58a2b29cce9e2bac700fa00859c63c1a4a8c41c70a9db96a5fc210960f463b SHA512 1595299811461b18cff490a8a56c0215f46989dd4a46fa087b455c717ed5d5f7a5782d04acaa3e4567b4e348bca866d5f24d21663012c4cd813445804ef6f714
diff --git a/dev-tex/dot2tex/dot2tex-2.11.3.ebuild b/dev-tex/dot2tex/dot2tex-2.11.3.ebuild
new file mode 100644
index 0000000..43787ab
--- /dev/null
+++ b/dev-tex/dot2tex/dot2tex-2.11.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Graphviz to LaTeX converter"
+HOMEPAGE="https://dot2tex.readthedocs.org/ https://github.com/kjellmf/dot2tex"
+SRC_URI="https://github.com/kjellmf/dot2tex/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="doc examples"
+
+DEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/pydot[${PYTHON_USEDEP}]
+ media-gfx/graphviz"
+DEPEND="${DEPEND}
+ doc? ( dev-python/sphinx )"
+
+python_compile_all() {
+ if use doc ; then
+ cd "${S}/docs"
+ emake html
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dohtml -r docs/_build/html/*
+ fi
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-util/itstool/Manifest b/dev-util/itstool/Manifest
new file mode 100644
index 0000000..4a22341
--- /dev/null
+++ b/dev-util/itstool/Manifest
@@ -0,0 +1 @@
+DIST itstool-2.0.6.tar.bz2 103067 BLAKE2B 72d3254cb88ef9d02f9b3509a46c2208e98bf6327f139e5d29b99cc6d80651bd41ea3bfb78e48e23cf7c217770cd8c6c74b00946ad9d2608a92925e43457edf0 SHA512 51058bdcb208f6fb84810f71f9bf67e42b00bf157a9756be45f060849c0aff36f695f4403404193720d4446818fa77de61fa94eed9e8789d26c07a2926072eb7
diff --git a/dev-util/itstool/itstool-2.0.6.ebuild b/dev-util/itstool/itstool-2.0.6.ebuild
new file mode 100644
index 0000000..e811060
--- /dev/null
+++ b/dev-util/itstool/itstool-2.0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_REQ_USE="xml"
+
+inherit python-single-r1
+
+DESCRIPTION="Translation tool for XML documents that uses gettext files and ITS rules"
+HOMEPAGE="http://itstool.org/"
+SRC_URI="http://files.itstool.org/itstool/${P}.tar.bz2"
+
+# files in /usr/share/itstool/its are HPND/as-is || GPL-3
+LICENSE="GPL-3+ || ( HPND GPL-3+ )"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-linux"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog NEWS ) # AUTHORS, README are empty
diff --git a/dev-vcs/stgit/Manifest b/dev-vcs/stgit/Manifest
deleted file mode 100644
index 28dd255..0000000
--- a/dev-vcs/stgit/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST stgit-0.18.tar.gz 235852 BLAKE2B ff35856c1f20a6a611a2faa22ba573b1c33636c9e913322456011c4c5a73c3207ddbd8bfe41cb81b11dffe8db8b89594c1598989ae9fb896cd686594a21d96b2 SHA512 5820cc1a8cdd5183fbe309b4b80568098844ff57934c75a43263b5cfcdac4b64e015abc9ed6a53dd856236d76bd0ebeec31e87561bca0d0d82a6e5ec7a10745f
diff --git a/dev-vcs/stgit/files/stgit-0.16-man-linkfix.patch b/dev-vcs/stgit/files/stgit-0.16-man-linkfix.patch
deleted file mode 100644
index 559cf8f..0000000
--- a/dev-vcs/stgit/files/stgit-0.16-man-linkfix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Documentation/Makefile 2012-07-08 23:55:38.958779174 +0200
-+++ b/Documentation/Makefile 2012-07-08 23:56:42.638010483 +0200
-@@ -72,7 +72,7 @@
- $(ASCIIDOC) -b xhtml11 -d manpage -f asciidoc.conf $(ASCIIDOC_EXTRA) $<
-
- %.1 : %.xml
-- xmlto -m callouts.xsl man $<
-+ xmlto -m callouts.xsl --stringparam man.base.url.for.relative.links=$(htmldir) man $<
-
- %.xml : %.txt
- $(ASCIIDOC) -b docbook -d manpage -f asciidoc.conf $<
diff --git a/dev-vcs/stgit/stgit-0.18.ebuild b/dev-vcs/stgit/stgit-0.18.ebuild
deleted file mode 100644
index 9a40c47..0000000
--- a/dev-vcs/stgit/stgit-0.18.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Manage a stack of patches using GIT as a backend"
-HOMEPAGE="http://www.procode.org/stgit/"
-UPSTREAM_VER=
-[[ -n ${UPSTREAM_VER} ]] && \
- UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
-
-SRC_URI="https://github.com/ctmarinas/stgit/archive/v${PV}.tar.gz -> ${P}.tar.gz
- ${UPSTREAM_PATCHSET_URI}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-RDEPEND=">=dev-vcs/git-1.6.3.3"
-
-# NOTE: It seems to be quite important which asciidoc version to use.
-# So keep an eye on it for the future.
-DEPEND="${RDEPEND}
- doc? (
- app-text/asciidoc
- app-text/xmlto
- dev-lang/perl
- )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.16-man-linkfix.patch"
-)
-
-pkg_setup() {
- if ! use doc; then
- echo
- ewarn "Manpages will not be built and installed."
- ewarn "Enable the 'doc' useflag, if you want them."
- echo
- fi
-}
-
-python_prepare_all() {
- # Upstream's patchset
- [[ -n ${UPSTREAM_VER} ]] && \
- eapply "${WORKDIR}"/patches-upstream
-
- # this will be a noop, as we are working with a tarball,
- # but throws git errors --> just get rid of it
- sed -i -e 's/version\.write_builtin_version()//' setup.py || die
-
- # write version ourselves
- if [[ ! -f stgit/builtin_version.py ]]; then
- echo "version = '${PV}'" > stgit/builtin_version.py
- fi
-
- distutils-r1_python_prepare_all
-}
-
-src_compile() {
- distutils-r1_src_compile
-
- # bug 526468
- if use doc; then
- emake DESTDIR="${D}" \
- htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
- mandir="${EPREFIX}/usr/share/man/" \
- doc
- fi
-}
-
-src_install() {
- if use doc; then
- emake DESTDIR="${D}" \
- htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
- mandir="${EPREFIX}/usr/share/man/" \
- install-doc install-html
- fi
-
- distutils-r1_src_install
-
- newbashcomp stgit-completion.bash 'stg'
-}
diff --git a/media-gfx/simple-scan/Manifest b/media-gfx/simple-scan/Manifest
deleted file mode 100644
index c5b443f..0000000
--- a/media-gfx/simple-scan/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST simple-scan-2.32.0.2.tar.gz 321317 SHA256 fa1ed81aa8e2343b3b70f2028dbfa44e1d9626e582936612c630d167b752206a SHA512 427dc2d20a1c955027f5f5ea7270d30d438e4987e4dd0ae48b145ec1be19ef4cf5587742965ecac112176c67b73c0784515d3de6eb19789b800a957e460f7406 WHIRLPOOL b5a2cac5bdc880129b28a7fbd7c398c7022d1af8814d0ea790bf7006e91c47a5dba6744b393909f91bdb55db5a8c28ecbf0d505ee586c99550be71d206959b31
diff --git a/media-gfx/simple-scan/simple-scan-2.32.0.2.ebuild b/media-gfx/simple-scan/simple-scan-2.32.0.2.ebuild
deleted file mode 100644
index e195dc6..0000000
--- a/media-gfx/simple-scan/simple-scan-2.32.0.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/simple-scan/simple-scan-2.32.0.2.ebuild,v 1.1 2011/04/26 21:23:11 eva Exp $
-
-EAPI=5
-
-GCONF_DEBUG="no"
-
-inherit autotools eutils gnome2
-
-DESCRIPTION="Simple document scanning utility"
-HOMEPAGE="https://launchpad.net/simple-scan"
-SRC_URI="http://launchpad.net/${PN}/2.32/${PV}/+download/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE=""
-
-COMMON_DEPEND="
- >=x11-libs/gtk+-2.18.0:2
- dev-libs/glib:2
- gnome-base/gconf:2
- >=media-gfx/sane-backends-1.0.20
- virtual/jpeg
- virtual/udev
- >=sys-libs/zlib-1.2.5
- x11-libs/cairo"
-RDEPEND="${COMMON_DEPEND}
- x11-misc/xdg-utils
- x11-themes/gnome-icon-theme"
-DEPEND="${COMMON_DEPEND}
- app-text/gnome-doc-utils
- gnome-base/gnome-common
- >=dev-util/intltool-0.35.0
- virtual/pkgconfig"
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-src_prepare() {
- gnome2_src_prepare
- eautoreconf
-}
diff --git a/net-libs/webkit-gtk/Manifest b/net-libs/webkit-gtk/Manifest
index 9a6c215..85a1fc6 100644
--- a/net-libs/webkit-gtk/Manifest
+++ b/net-libs/webkit-gtk/Manifest
@@ -1 +1 @@
-DIST webkitgtk-2.4.11.tar.xz 9869100 SHA256 588aea051bfbacced27fdfe0335a957dca839ebe36aa548df39c7bbafdb65bf7 SHA512 2e2cf01a52b8593765a0a3c2d7f0ad306121660019eb402226bd2826c7d4666dab4e91ca6ccbd29abe0ad3993549f256ed1ab88de22e9c8516d5f40a4edd6bfb WHIRLPOOL de86c4abfb22aacbf62163d0398158931c9cf6ab628547d3b30e613f0505d67c85c3200f7db96500e7c2b35f640cdaa7f501346fc13f492c9439dff4056849a3
+DIST webkitgtk-2.4.11.tar.xz 9869100 BLAKE2B 9b1351976dc753025e6aba86a40f97fdf58821a6a7af109140a18adc7a0e1d8c140711b48bceeb3c4c189e7d52f258520623c7d971c46b6f2572c0e1de0d0100 SHA512 2e2cf01a52b8593765a0a3c2d7f0ad306121660019eb402226bd2826c7d4666dab4e91ca6ccbd29abe0ad3993549f256ed1ab88de22e9c8516d5f40a4edd6bfb
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.4.11-r201.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.4.11-r201.ebuild
index 8bef588..af8aad9 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.4.11-r201.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.4.11-r201.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
PYTHON_COMPAT=( python2_7 )
-USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+USE_RUBY="ruby22 ruby23 ruby24"
inherit autotools check-reqs flag-o-matic gnome2 pax-utils python-any-r1 ruby-single toolchain-funcs versionator virtualx
@@ -172,6 +172,12 @@ src_configure() {
# Respect CC, otherwise fails on prefix #395875
tc-export CC
+ # revert icu behavior
+ append-cxxflags -DUPRV_BLOCK_MACRO_BEGIN=\"\" -DUPRV_BLOCK_MACRO_END=\"\"
+
+ # disable warnings
+ append-cxxflags -w
+
# Arches without JIT support also need this to really disable it in all places
use jit || append-cppflags -DENABLE_JIT=0 -DENABLE_YARR_JIT=0 -DENABLE_ASSEMBLER=0
@@ -196,14 +202,12 @@ src_configure() {
local ruby_interpreter=""
- if has_version "virtual/rubygems[ruby_targets_ruby23]"; then
+ if has_version "virtual/rubygems[ruby_targets_ruby24]"; then
+ ruby_interpreter="RUBY=$(type -P ruby24)"
+ elif has_version "virtual/rubygems[ruby_targets_ruby23]"; then
ruby_interpreter="RUBY=$(type -P ruby23)"
elif has_version "virtual/rubygems[ruby_targets_ruby22]"; then
ruby_interpreter="RUBY=$(type -P ruby22)"
- elif has_version "virtual/rubygems[ruby_targets_ruby21]"; then
- ruby_interpreter="RUBY=$(type -P ruby21)"
- else
- ruby_interpreter="RUBY=$(type -P ruby20)"
fi
# TODO: Check Web Audio support
diff --git a/net-news/feed2imap/feed2imap-9999.ebuild b/net-news/feed2imap/feed2imap-9999.ebuild
index e026da1..88c62e3 100644
--- a/net-news/feed2imap/feed2imap-9999.ebuild
+++ b/net-news/feed2imap/feed2imap-9999.ebuild
@@ -2,12 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23"
+EAPI=7
+USE_RUBY="ruby25"
-EGIT_REPO_URI="git://git.necoro.eu/others/feed2imap"
-EGIT_BRANCH="ruby22"
-inherit git-2 ruby-ng
+EGIT_REPO_URI="https://git.necoro.eu/others/feed2imap.git"
+EGIT_BRANCH="necoro"
+inherit git-r3 ruby-single