summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2010-05-11 19:34:58 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2010-05-11 19:34:58 +0200
commit264fef834ab10fc672eb72bbf7da822e2a93a578 (patch)
treea7bcce1a09755e7dde3afe825baa15d849959ec0 /setup.py
parentabc4db5913bebc4d16b22d8856dba16c695a1477 (diff)
parent8c016e8ace989e3e1d0dadd7e54e61849341168f (diff)
downloadportato-264fef834ab10fc672eb72bbf7da822e2a93a578.tar.gz
portato-264fef834ab10fc672eb72bbf7da822e2a93a578.tar.bz2
portato-264fef834ab10fc672eb72bbf7da822e2a93a578.zip
Pre-release merge
Merge branch '0.14' * 0.14: Fix release script pathes Add '--plugin-dir' option Add a README message to the release Add a release file Improve setup.py for release script Improve constants.py for release script
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 8 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 766b2a2..5334b64 100644
--- a/setup.py
+++ b/setup.py
@@ -42,17 +42,22 @@ data_files = [
cmdclass = {'build_manpage': build_manpage}
# remove useless options / they are the default
-for o in ("cython", "eix"):
+for o in (
+ "eix",
+ "cython", #!REMOVE
+ ):
try:
sys.argv.remove("--enable-"+o)
except ValueError:
pass
# extension stuff
-if "--disable-cython" in sys.argv:
- sys.argv.remove("--disable-cython")
+#!INSERT if not "--enable-cython" in sys.argv:
+if "--disable-cython" in sys.argv: #!REMOVE
+ sys.argv.remove("--disable-cython") #!REMOVE
ext = "c"
else:
+ #!INSERT sys.argv.remove("--enable-cython")
from Cython.Distutils import build_ext
cmdclass['build_ext'] = build_ext
ext = "pyx"