summaryrefslogtreecommitdiff
path: root/x11-misc/pdfpres/pdfpres-0.2.3_p1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/pdfpres/pdfpres-0.2.3_p1.ebuild')
-rw-r--r--x11-misc/pdfpres/pdfpres-0.2.3_p1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/pdfpres/pdfpres-0.2.3_p1.ebuild b/x11-misc/pdfpres/pdfpres-0.2.3_p1.ebuild
new file mode 100644
index 0000000..0986cf7
--- /dev/null
+++ b/x11-misc/pdfpres/pdfpres-0.2.3_p1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit eutils python vcs-snapshot
+
+REV=404908827b4eb1eef8e54a71dbb7067b270fbc1b
+
+DESCRIPTION="Dual head PDF presenter"
+HOMEPAGE="http://www.uninformativ.de/projects/?q=pdfpres"
+SRC_URI="https://github.com/vain/${PN}/archive/${REV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix_fullscreen.patch"
+}
+
+src_install() {
+ dodoc README || die
+
+ newbin legacy-notes-converter.py ${PN}-legacy-notes-converter || die
+ python_convert_shebangs 2 "${D}"/usr/bin/${PN}-legacy-notes-converter || die
+
+ dobin ${PN} || die
+ doman man1/${PN}.1 || die
+}