summaryrefslogtreecommitdiff
path: root/dev-python/wtforms/wtforms-1.0.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wtforms/wtforms-1.0.5.ebuild')
-rw-r--r--dev-python/wtforms/wtforms-1.0.5.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/wtforms/wtforms-1.0.5.ebuild b/dev-python/wtforms/wtforms-1.0.5.ebuild
deleted file mode 100644
index f15fc76..0000000
--- a/dev-python/wtforms/wtforms-1.0.5.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/wtforms-1.0.4.ebuild,v 1.4 2013/09/05 18:46:09 mgorny Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
-
-inherit distutils-r1
-
-MY_PN="WTForms"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Flexible forms validation and rendering library for python web development"
-HOMEPAGE="http://wtforms.simplecodes.com/ http://pypi.python.org/pypi/WTForms"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND="app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-DOCS="AUTHORS.txt CHANGES.txt README.txt"
-
-python_test() {
- esetup.py test || die "Tests failed for ${EPYTHON}"
-}
-
-python_compile_all() {
- if use doc; then
- einfo "Generation of documentation"
- cd docs
- PYTHONPATH=".." emake html || die "Building of documentation failed"
- fi
-}
-
-python_install_all() {
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-}