summaryrefslogtreecommitdiff
path: root/dev-python/lxml/files/lxml-2.0.3-no-fake-pyrex.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lxml/files/lxml-2.0.3-no-fake-pyrex.patch')
-rw-r--r--dev-python/lxml/files/lxml-2.0.3-no-fake-pyrex.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/dev-python/lxml/files/lxml-2.0.3-no-fake-pyrex.patch b/dev-python/lxml/files/lxml-2.0.3-no-fake-pyrex.patch
new file mode 100644
index 0000000..9042ae6
--- /dev/null
+++ b/dev-python/lxml/files/lxml-2.0.3-no-fake-pyrex.patch
@@ -0,0 +1,15 @@
+--- setup.py 2008-04-07 15:10:32.989740409 +0300
++++ setup.py 2008-04-07 15:11:13.897709903 +0300
+@@ -4,10 +4,9 @@
+
+ try:
+ import Cython
+- # may need to work around setuptools bug by providing a fake Pyrex
+- sys.path.insert(0, os.path.join(os.path.dirname(__file__), "fake_pyrex"))
+ except ImportError:
+- pass
++ print >>sys.stderr, "lxml requires cython-0.9.6.10 or later."
++ sys.exit(1)
+
+ try:
+ import pkg_resources