summaryrefslogtreecommitdiff
path: root/dev-python/empy/empy-3_bin.diff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/empy/empy-3_bin.diff')
-rw-r--r--dev-python/empy/empy-3_bin.diff31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/empy/empy-3_bin.diff b/dev-python/empy/empy-3_bin.diff
new file mode 100644
index 0000000..37fab44
--- /dev/null
+++ b/dev-python/empy/empy-3_bin.diff
@@ -0,0 +1,31 @@
+--- /usr/portage/dev-python/empy/empy-3.3.ebuild 2007-06-25 10:06:03.000000000 +0200
++++ empy-3.3.ebuild 2008-07-21 22:44:54.000000000 +0200
+@@ -2,7 +2,7 @@
+ # Distributed under the terms of the GNU General Public License v2
+ # $Header: /var/cvsroot/gentoo-x86/dev-python/empy/empy-3.3.ebuild,v 1.9 2007/06/25 07:40:06 hawking Exp $
+
+-inherit distutils
++inherit python
+
+ DESCRIPTION="A powerful and robust templating system for Python"
+ HOMEPAGE="http://www.alcyone.com/software/empy/"
+@@ -21,11 +21,8 @@
+ }
+
+ src_install() {
+- distutils_src_install
+- distutils_python_version
+- dodir /usr/bin
+- fperms 755 /usr/lib/python${PYVER}/site-packages/em.py
+- dosym /usr/lib/python${PYVER}/site-packages/em.py /usr/bin/em.py
++ cd ${S}
++ dobin em.py
+ dodir /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins sample.em sample.bench
+@@ -33,4 +30,5 @@
+ dohtml doc/home/max/projects/empy/doc/em/*
+ dohtml doc/home/max/projects/empy/doc/em.html
+ dohtml doc/index.html
++ dodoc README
+ }