summaryrefslogtreecommitdiff
path: root/dev-lang/polyml/polyml-5.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/polyml/polyml-5.5.1.ebuild')
-rw-r--r--dev-lang/polyml/polyml-5.5.1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-lang/polyml/polyml-5.5.1.ebuild b/dev-lang/polyml/polyml-5.5.1.ebuild
deleted file mode 100644
index ce344d5..0000000
--- a/dev-lang/polyml/polyml-5.5.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/polyml/polyml-5.5.0.ebuild,v 1.3 2012/12/05 09:49:35 gienah Exp $
-
-EAPI="5"
-
-inherit base autotools versionator
-
-MY_P="${PN}.${PV}"
-
-DESCRIPTION="Poly/ML is a full implementation of Standard ML"
-HOMEPAGE="http://www.polyml.org"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="X elibc_glibc +gmp portable test +threads"
-
-RDEPEND="X? ( x11-libs/motif )
- gmp? ( >=dev-libs/gmp-5 )
- elibc_glibc? ( threads? ( >=sys-libs/glibc-2.13 ) )
- virtual/libffi"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=("${FILESDIR}/${PN}-5.5.0-asm.patch")
-
-src_prepare() {
- base_src_prepare
- eautoreconf
-}
-
-src_configure() {
- econf \
- --with-system-libffi \
- $(use_with X x) \
- $(use_with gmp) \
- $(use_with portable) \
- $(use_with threads)
-}
-
-src_test() {
- emake tests || die "tests failed"
-}