summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/gtksourceview/Manifest3
-rw-r--r--x11-libs/gtksourceview/files/2.0/gentoo.lang68
-rw-r--r--x11-libs/gtksourceview/gtksourceview-2.0.2.ebuild37
3 files changed, 0 insertions, 108 deletions
diff --git a/x11-libs/gtksourceview/Manifest b/x11-libs/gtksourceview/Manifest
deleted file mode 100644
index 6cb60ff..0000000
--- a/x11-libs/gtksourceview/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-AUX 2.0/gentoo.lang 2675 RMD160 1c2baf2af76c8e83d3d09b3558d53b7764caaa9a SHA1 38b36b7f62c39f46a7f9792a361ce2136ada8ed9 SHA256 b5eeb038297cb1892d100e8cc912f39b7b7ff5027152aa7cbfe7ce1966485715
-DIST gtksourceview-2.0.2.tar.bz2 1020145 RMD160 01cd574a70ec684217e5a95458b33aa3c8b31a6d SHA1 df728a822b55dc6c3370e011c8904a5be5c357a8 SHA256 bd775a331aec8fe682e123773a0609fd673256437c950ced8415ab56eb292e39
-EBUILD gtksourceview-2.0.2.ebuild 993 RMD160 265e873e4ce1cc8a768dac978c3917fd0fc7d1b9 SHA1 e7986abbdf9c71e74c0c0561d14bbf7d2e272028 SHA256 a78249a6f64fa334701a51c0fdbb551060bf7ec104ce69ce3e127ae404fe7cc8
diff --git a/x11-libs/gtksourceview/files/2.0/gentoo.lang b/x11-libs/gtksourceview/files/2.0/gentoo.lang
deleted file mode 100644
index dc4857d..0000000
--- a/x11-libs/gtksourceview/files/2.0/gentoo.lang
+++ /dev/null
@@ -1,68 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!--
- GtkSourceView syntax highlight for Gentoo-specific files
-
- Originally written for gtksourceview-1.x by:
- Leonardo Ferreira Fontenelle <leo.fontenelle@gmail.com>, 2006.
- Rewritten for gtksourceview-2 by:
- Rene 'Necoro' Neumann <necoro@necoro.net>, 2007-2008
-
- Distributed under the same license(s) as gtksourceview.
-
- TODO:
- - do not highlight "enable" in the configure options
- - perhaps highlight portage variables and portage functions different
-
--->
-
-<language name="gentoo" id="gentoo" version="2.0" _section="Scripts">
- <metadata>
- <property name="mimetypes">text/plain</property>
- <property name="globs">*.ebuild;*.eclass</property>
- <property name="line-comment-start">#</property>
- </metadata>
-
- <styles>
- <style id="variable" _name="Portage variables" map-to="def:builtin" />
- <style id="command" _name="Portage command" map-to="def:type" />
- <style id="function" _name="Portage function" map-to="def:function" />
- <style id="string" _name="String" map-to="def:string" />
- </styles>
-
- <definitions>
-
- <!-- portage variables - currently unused -->
- <context id="portvars" style-ref="variable">
- <match>\b((ARCH|HOMEPAGE|DESCRIPTION|IUSE|SRC_URI|LICENSE|SLOT|KEYWORDS|FILESDIR|WORKDIR|(P|R)?DEPEND|PROVIDE|DISTDIR|RESTRICT|USERLAND)|(S|D|T|PV|PF|P|PN|A)|C(XX)?FLAGS|LDFLAGS|C(HOST|TARGET|BUILD))\b</match>
- </context>
-
- <!-- portage functions - currently unused -->
- <context id="portfuncs" style-ref="function">
- <match>^(src_(unpack|compile|install|test)|pkg_(config|nofetch|setup|(pre|post)(inst|rm)))</match>
- </context>
-
- <!-- extra portage commands -->
- <context id="portcmds" style-ref="command">
- <match>\b(e(begin|end|conf|install|make|log|warn|infon?|error|patch)|die|use(_(with|enable))?|inherit|has|(has|best)_version|unpack|(do|new)(ins|s?bin|doc|lib(|\.so|\.a)|man|info|exe|initd|confd|envd|pam|menu|icon)|do(python|sed|dir|hard|sym|html|jar|mo)|keepdir|prepall(|docs|info|man|strip)|prep(info|lib|lib\.(so|a)|man|strip)|(|doc|ins|exe)into|f(owners|perms)|(exe|ins|dir)opts)\b</match>
- </context>
-
- <context id="built-in-command">
- <include> <!-- do not include "sh:built-in-command" as it is replaced down there - which would lead to an endless loop -->
- <context ref="sh:built-in-command-1" />
- <context ref="sh:built-in-command-2" />
- <context ref="sh:for-command" />
- <context ref="portcmds" />
- </include>
- </context>
-
- <!-- gentoo is just a shell with the replacements -->
- <replace id="sh:built-in-command" ref="built-in-command" />
-
- <context id="gentoo">
- <include>
- <context ref="sh:sh" />
- </include>
- </context>
- </definitions>
-</language>
diff --git a/x11-libs/gtksourceview/gtksourceview-2.0.2.ebuild b/x11-libs/gtksourceview/gtksourceview-2.0.2.ebuild
deleted file mode 100644
index 2a23130..0000000
--- a/x11-libs/gtksourceview/gtksourceview-2.0.2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/gtksourceview-2.0.2.ebuild,v 1.8 2008/02/04 04:20:02 jer Exp $
-
-inherit gnome2 eutils autotools
-
-DESCRIPTION="A text widget implementing syntax highlighting and other features"
-HOMEPAGE="http://www.gnome.org/"
-
-LICENSE="GPL-2"
-SLOT="2.0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd"
-IUSE="doc"
-
-RDEPEND=">=x11-libs/gtk+-2.8
- >=dev-libs/libxml2-2.5
- >=dev-libs/glib-2
- >=dev-libs/libpcre-7.4"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- >=dev-util/intltool-0.35
- >=dev-util/pkgconfig-0.9
- doc? ( >=dev-util/gtk-doc-1 )"
-
-DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
-
-pkg_setup() {
- # Removes the gnome-vfs dep
- G2CONF="${G2CONF} --disable-build-tests --with-system-pcre"
-}
-
-src_install() {
- gnome2_src_install
-
- insinto /usr/share/${PN}-2.0/language-specs
- doins "${FILESDIR}"/2.0/gentoo.lang
-}