summaryrefslogtreecommitdiff
path: root/x11-misc
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2008-06-25 11:20:34 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2008-06-25 11:20:34 +0200
commit763483fce6c1427518c2e1862aad42172b93e6f2 (patch)
tree5553e958deef536637a31fe5895cefa3d09b2888 /x11-misc
parent7747c91e6267d1fb9e3e28eeadb1d46d204b003c (diff)
downloadoverlay-763483fce6c1427518c2e1862aad42172b93e6f2.tar.gz
overlay-763483fce6c1427518c2e1862aad42172b93e6f2.tar.bz2
overlay-763483fce6c1427518c2e1862aad42172b93e6f2.zip
Added notification-daemon-xfce w/o this strange gradient look
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/notification-daemon-xfce/Manifest3
-rw-r--r--x11-misc/notification-daemon-xfce/files/0.3.7/01_all_fix_autoconf.patch12
-rw-r--r--x11-misc/notification-daemon-xfce/notification-daemon-xfce-0.3.7.ebuild50
3 files changed, 65 insertions, 0 deletions
diff --git a/x11-misc/notification-daemon-xfce/Manifest b/x11-misc/notification-daemon-xfce/Manifest
new file mode 100644
index 0000000..e29fab3
--- /dev/null
+++ b/x11-misc/notification-daemon-xfce/Manifest
@@ -0,0 +1,3 @@
+AUX 0.3.7/01_all_fix_autoconf.patch 618 RMD160 80cbe02dbcfcf0f65551fc64d8c5b71130e38e43 SHA1 f44786ff03e1074574551f35a7a3fcd85138b3b7 SHA256 79f5fc30ca1487e594fc651f5ee8fc2a6501cf7ac9fa4da8e914545712dd2238
+DIST notification-daemon-xfce-0.3.7.tar.bz2 329496 RMD160 d5df3795d7d7a5f5fceee6ac7672c7e173f01070 SHA1 46d8dead23db347db7aae56b90ecca4a1dedf545 SHA256 c0dc4100a9fc6cbc45ce8741fd360f4d80ad57ced6905e42a70a92855d09a38a
+EBUILD notification-daemon-xfce-0.3.7.ebuild 1434 RMD160 b097c9d27e61ace4166c2a2cb0b0fc3a40def515 SHA1 a5d97aa90f471dbf55e801cfdcc1a4fee49c7a21 SHA256 cf399f26dcd72bfa088f5007b5af76c31d76f60cee1687e93a3d4ab3b45ff330
diff --git a/x11-misc/notification-daemon-xfce/files/0.3.7/01_all_fix_autoconf.patch b/x11-misc/notification-daemon-xfce/files/0.3.7/01_all_fix_autoconf.patch
new file mode 100644
index 0000000..1d7ab50
--- /dev/null
+++ b/x11-misc/notification-daemon-xfce/files/0.3.7/01_all_fix_autoconf.patch
@@ -0,0 +1,12 @@
+diff -ur notification-daemon-xfce-0.3.7.orig/configure.in notification-daemon-xfce-0.3.7/configure.in
+--- notification-daemon-xfce-0.3.7.orig/configure.in 2007-05-26 12:52:28.000000000 +0300
++++ notification-daemon-xfce-0.3.7/configure.in 2008-06-23 04:38:53.000000000 +0300
+@@ -18,7 +18,7 @@
+ dnl *********************
+ dnl *** init autoconf ***
+ dnl *********************
+-AC_INIT([notification-daemon-xfce], [notification_daemon_version()], [http://bugzilla.xfce.org/])
++AC_INIT([notification-daemon-xfce], [notification_daemon_version], [http://bugzilla.xfce.org/])
+ AC_PREREQ([2.50])
+
+ dnl *********************
diff --git a/x11-misc/notification-daemon-xfce/notification-daemon-xfce-0.3.7.ebuild b/x11-misc/notification-daemon-xfce/notification-daemon-xfce-0.3.7.ebuild
new file mode 100644
index 0000000..391ee64
--- /dev/null
+++ b/x11-misc/notification-daemon-xfce/notification-daemon-xfce-0.3.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon-xfce/notification-daemon-xfce-0.3.7.ebuild,v 1.3 2008/06/24 19:57:45 drac Exp $
+
+EAPI=1
+
+inherit autotools eutils
+
+DESCRIPTION="Port of notification daemon for Xfce Desktop Environment"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/notification-daemon-xfce"
+SRC_URI="http://goodies.xfce.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ~ppc64 sparc x86 ~x86-fbsd"
+IUSE="debug +xfce"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.6
+ >=xfce-base/libxfcegui4-4.3.90
+ >=xfce-base/libxfce4util-4.3.90
+ xfce? ( >=xfce-base/xfce-mcs-manager-4.2.2 )
+ >=x11-libs/libsexy-0.1.3
+ dev-libs/dbus-glib"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext
+ dev-util/xfce4-dev-tools
+ !x11-misc/notification-daemon"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ EPATCH_SUFFIX="patch" epatch "${FILESDIR}"/${PV}
+ intltoolize --force --copy --automake || die "intltoolize failed."
+ AT_M4DIR="/usr/share/xfce4/dev-tools/m4macros" eautoreconf
+}
+
+src_compile() {
+ econf --disable-dependency-tracking \
+ $(use_enable debug) \
+ $(use_enable xfce mcs-plugin)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+}