summaryrefslogtreecommitdiff
path: root/www-servers/hiawatha/hiawatha-9.1.1.ebuild
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2013-04-25 18:50:26 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2013-04-25 18:50:26 +0200
commitc7f7803349508e17bbc3e6a78809ae9d5639b2f1 (patch)
tree14dbf8aeedfc42d0eb1566d658027b1d0241ad16 /www-servers/hiawatha/hiawatha-9.1.1.ebuild
parent920341bdf91a6e2b58f92effbb7d0b4e71fd8fbc (diff)
downloadoverlay-c7f7803349508e17bbc3e6a78809ae9d5639b2f1.tar.gz
overlay-c7f7803349508e17bbc3e6a78809ae9d5639b2f1.tar.bz2
overlay-c7f7803349508e17bbc3e6a78809ae9d5639b2f1.zip
Hiawatha changes
Diffstat (limited to 'www-servers/hiawatha/hiawatha-9.1.1.ebuild')
-rw-r--r--www-servers/hiawatha/hiawatha-9.1.1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/www-servers/hiawatha/hiawatha-9.1.1.ebuild b/www-servers/hiawatha/hiawatha-9.1.1.ebuild
new file mode 100644
index 0000000..f397f98
--- /dev/null
+++ b/www-servers/hiawatha/hiawatha-9.1.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+CMAKE_MIN_VERSION="2.8.4"
+
+inherit cmake-utils
+
+DESCRIPTION="Advanced and secure webserver"
+HOMEPAGE="http://www.hiawatha-webserver.org"
+SRC_URI="http://www.hiawatha-webserver.org/files/${P}.tar.gz"
+
+# NB: version 9.1.1 is a "Gentoo-only" release, which removed the dependency on
+# the bundled PolarSSL
+# --> it is not anounced on the hiawatha homepage
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug +cache ipv6 monitor +rewrite rproxy ssl tomahawk +xslt"
+
+DEPEND="
+ sys-libs/zlib
+ ssl? ( >=net-libs/polarssl-1.2 )
+ xslt? ( dev-libs/libxslt
+ dev-libs/libxml2 )"
+
+RDEPEND="${DEPEND}"
+PDEPEND="monitor? ( www-apps/hiawatha-monitor )"
+
+pkg_setup() {
+ if ! use xslt; then
+ ewarn "XSLT has been disabled on your request."
+ ewarn "Note that XSLT is needed for directory listings."
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable cache CACHE)
+ $(cmake-utils_use_enable ipv6 IPV6)
+ $(cmake-utils_use_enable debug DEBUG)
+ $(cmake-utils_use_enable monitor MONITOR)
+ $(cmake-utils_use_enable rewrite TOOLKIT)
+ $(cmake-utils_use_enable rproxy RPROXY)
+ $(cmake-utils_use_enable ssl SSL)
+ $(cmake-utils_use_use ssl SYSTEM_POLARSSL)
+ $(cmake-utils_use_enable tomahawk TOMAHAWK)
+ $(cmake-utils_use_enable xslt XSLT)
+
+ $(cmake_utils_use_enable kernel_linux LOADCHECK)
+ -DLOG_DIR:STRING=/var/log/hiawatha
+ -DPID_DIR:STRING=/var/run
+ -DWEBROOT_DIR:STRING=/var/www/hiawatha
+ -DWORK_DIR:STRING=/var/lib/hiawatha
+ -DCONFIG_DIR:STRING=/etc/hiawatha
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ newinitd "${FILESDIR}"/hiawatha.initd hiawatha
+
+ keepdir /var/{lib,log}/hiawatha
+}