summaryrefslogtreecommitdiff
path: root/www-servers/hiawatha/files
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2013-04-20 16:51:45 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2013-04-20 16:51:45 +0200
commitbf2d3e103c99284e1e93948a5b50b41feb253196 (patch)
treef6d0c216653a19150e5092ff814330350d022265 /www-servers/hiawatha/files
parent95b46451fadf62bc1f40989b3dabb550efd756e1 (diff)
downloadoverlay-bf2d3e103c99284e1e93948a5b50b41feb253196.tar.gz
overlay-bf2d3e103c99284e1e93948a5b50b41feb253196.tar.bz2
overlay-bf2d3e103c99284e1e93948a5b50b41feb253196.zip
Hiawatha-9.0
Diffstat (limited to 'www-servers/hiawatha/files')
-rw-r--r--www-servers/hiawatha/files/hiawatha-9.0-no-bundled-polarssl.patch30
-rw-r--r--www-servers/hiawatha/files/hiawatha.initd22
2 files changed, 52 insertions, 0 deletions
diff --git a/www-servers/hiawatha/files/hiawatha-9.0-no-bundled-polarssl.patch b/www-servers/hiawatha/files/hiawatha-9.0-no-bundled-polarssl.patch
new file mode 100644
index 0000000..d48afd4
--- /dev/null
+++ b/www-servers/hiawatha/files/hiawatha-9.0-no-bundled-polarssl.patch
@@ -0,0 +1,30 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1f4a312..0d8c6ca 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -92,15 +92,11 @@ include(CPack)
+
+ # PolarSSL
+ if(ENABLE_SSL)
+- option(USE_SHARED_POLARSSL_LIBRARY "Build PolarSSL as a shared library." ON)
+- set(CMAKE_INSTALL_NAME_DIR ${CMAKE_INSTALL_FULL_LIBDIR}/hiawatha)
+- set(LIB_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}/hiawatha)
+- add_subdirectory(polarssl)
+- set(POLARSSL_LIBRARY "polarssl")
++ find_library(POLARSSL_LIBRARY polarssl)
+ endif()
+
+ # Hiawatha
+-include_directories(${CMAKE_CURRENT_BINARY_DIR} polarssl/include)
++include_directories(${CMAKE_CURRENT_BINARY_DIR})
+ if(ENABLE_XSLT)
+ include_directories(${LIBXML2_INCLUDE_DIR} ${LIBXSLT_INCLUDE_DIR})
+ endif()
+@@ -124,7 +120,6 @@ target_link_libraries(wigwam ${CRYPT_LIBRARY})
+ target_link_libraries(hiawatha ${CRYPT_LIBRARY} pthread ${Z_LIBRARY})
+ if(ENABLE_SSL)
+ target_link_libraries(hiawatha ${POLARSSL_LIBRARY})
+- set_target_properties(hiawatha PROPERTIES INSTALL_RPATH ${CMAKE_INSTALL_FULL_LIBDIR}/hiawatha)
+ endif()
+ if(ENABLE_XSLT)
+ target_link_libraries(hiawatha ${LIBXML2_LIBRARIES} ${LIBXSLT_LIBRARIES})
diff --git a/www-servers/hiawatha/files/hiawatha.initd b/www-servers/hiawatha/files/hiawatha.initd
new file mode 100644
index 0000000..fc6d3a4
--- /dev/null
+++ b/www-servers/hiawatha/files/hiawatha.initd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --exec "/usr/sbin/hiawatha" \
+ --pidfile "/var/run/hiawatha.pid"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --exec "/usr/sbin/hiawatha" \
+ --pidfile "/var/run/hiawatha.pid"
+ eend $?
+}