summaryrefslogtreecommitdiff
path: root/dev-vcs
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2011-04-03 21:58:09 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2011-04-03 21:58:09 +0200
commit85aac1692448d7d7863c3300e0a0d4c40aeae7bb (patch)
tree22816b74838464299e6460bacb4836d9ebc1432b /dev-vcs
parent44a9f236d220ae01addf7913060731fab858dedc (diff)
downloadoverlay-85aac1692448d7d7863c3300e0a0d4c40aeae7bb.tar.gz
overlay-85aac1692448d7d7863c3300e0a0d4c40aeae7bb.tar.bz2
overlay-85aac1692448d7d7863c3300e0a0d4c40aeae7bb.zip
gitosis-gentoo ebuild
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/gitosis-gentoo/Manifest1
-rw-r--r--dev-vcs/gitosis-gentoo/gitosis-gentoo-9999.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-vcs/gitosis-gentoo/Manifest b/dev-vcs/gitosis-gentoo/Manifest
new file mode 100644
index 0000000..b808dfe
--- /dev/null
+++ b/dev-vcs/gitosis-gentoo/Manifest
@@ -0,0 +1 @@
+EBUILD gitosis-gentoo-9999.ebuild 962 RMD160 7dd1b52947618cddf9500cd1596681dbb79db7a8 SHA1 c6ed503ea6ef789dcc521c5d681fbcaecb3a7af6 SHA256 21005f7c9051245ff44786ddb7006c237b6b88ef7880fd190fecf6d1c954a256
diff --git a/dev-vcs/gitosis-gentoo/gitosis-gentoo-9999.ebuild b/dev-vcs/gitosis-gentoo/gitosis-gentoo-9999.ebuild
new file mode 100644
index 0000000..901346a
--- /dev/null
+++ b/dev-vcs/gitosis-gentoo/gitosis-gentoo-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20100721.ebuild,v 1.1 2010/07/21 15:47:28 robbat2 Exp $
+
+EAPI=3
+EGIT_REPO_URI="git://necoro.eu/others/gitosis.git"
+inherit eutils distutils git
+
+DESCRIPTION="gitosis -- software for hosting git repositories, Gentoo fork, Necoro fork"
+HOMEPAGE="https://github.com/Necoro/gitosis"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE=""
+DEPEND_GIT=">=dev-vcs/git-1.5.6.4"
+DEPEND="${DEPEND_GIT}
+ >=dev-python/setuptools-0.6_rc5"
+RDEPEND="${DEPEND}
+ !dev-vcs/gitosis"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="example.conf gitweb.conf lighttpd-gitweb.conf TODO.rst"
+
+pkg_setup() {
+ enewgroup git
+ enewuser git -1 /bin/sh /var/git git
+}
+
+src_install() {
+ distutils_src_install
+ keepdir /var/git/repositories
+ fowners git:git /var/git/repositories
+}