summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2009-11-10 01:30:14 +0100
committerRené 'Necoro' Neumann <necoro@necoro.net>2009-11-10 01:30:14 +0100
commitac13771cb246f4ded9d0cdcec9e7519d9101bfff (patch)
treeae3fe563cb68a46de5f81f448981300f7ed67865 /dev-util
parentea422c93badcd1116b2349d152ab7ac875a8958c (diff)
downloadoverlay-ac13771cb246f4ded9d0cdcec9e7519d9101bfff.tar.gz
overlay-ac13771cb246f4ded9d0cdcec9e7519d9101bfff.tar.bz2
overlay-ac13771cb246f4ded9d0cdcec9e7519d9101bfff.zip
Add stgit-0.15
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/stgit/Manifest2
-rw-r--r--dev-util/stgit/stgit-0.15.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/stgit/Manifest b/dev-util/stgit/Manifest
new file mode 100644
index 0000000..54dcab4
--- /dev/null
+++ b/dev-util/stgit/Manifest
@@ -0,0 +1,2 @@
+DIST stgit-0.15.tar.gz 342320 RMD160 3779091ed8639c825f053c66031b4569a6ffbdea SHA1 8f18e3079014d907237aeffa6b851074422b7f27 SHA256 691fe26dc0c0691cb65fa2763c437eaafc28c107a4d64a03653ce613414ff84d
+EBUILD stgit-0.15.ebuild 1425 RMD160 3fa04653f66f43f105f598bbb02c02041befe4e5 SHA1 a8fbe5d794304e11948d93e6164130581d21bcd9 SHA256 10dd2f7c8eaf9c42b86f934fd05c20d435d840cc76d18afb304179a00697c642
diff --git a/dev-util/stgit/stgit-0.15.ebuild b/dev-util/stgit/stgit-0.15.ebuild
new file mode 100644
index 0000000..c2796a3
--- /dev/null
+++ b/dev-util/stgit/stgit-0.15.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit distutils bash-completion
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="http://www.procode.org/stgit/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-util/git-1.6.3.3"
+
+# NOTE: It seems to be quite important which asciidoc version to use.
+# So keep an eye on it for the future. Reference should be the online
+# man pages. (As of this writing, they use 8.2.7).
+DEPEND="$RDEPEND
+ =app-text/asciidoc-8.2*
+ app-text/xmlto
+ dev-lang/perl"
+
+src_prepare() {
+ # setup.cfg defaults to ~ ... delete it instead of sed'ing
+ rm setup.cfg
+ distutils_src_prepare
+}
+
+src_compile() {
+ # git throws errors if it cannot write its config file
+ # thus feed it a dummy one
+ touch gitconfig
+ export GIT_CONFIG="${S}/gitconfig"
+
+ # preparation stuff done in the makefile
+ emake build doc || die "emake failed"
+
+ # do not call normal 'emake' to use our own python handling
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ doman Documentation/*.1 || die "doman failed"
+
+ insinto /usr/share/doc/${PF}
+ doins Documentation/tutorial.html || die "doins failed"
+
+ mv "${D}/usr/share/${PN}/examples" "${D}/usr/share/doc/${PF}"
+ dobashcompletion stgit-completion.bash ${PN}
+}