summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2008-09-02 14:14:42 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2008-09-02 14:14:42 +0200
commitd469d98a9db0af5e7d14b43ca4054617118d2ab3 (patch)
treebf94b569629168d82b4ea11de7153cf8d583384e /dev-python
parent49291aaf16e0507fa2524eec0cd375d1a1ea1314 (diff)
downloadoverlay-d469d98a9db0af5e7d14b43ca4054617118d2ab3.tar.gz
overlay-d469d98a9db0af5e7d14b43ca4054617118d2ab3.tar.bz2
overlay-d469d98a9db0af5e7d14b43ca4054617118d2ab3.zip
Add bpython
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/bpython/Manifest1
-rw-r--r--dev-python/bpython/bpython-9999.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/bpython/Manifest b/dev-python/bpython/Manifest
new file mode 100644
index 0000000..058ebc4
--- /dev/null
+++ b/dev-python/bpython/Manifest
@@ -0,0 +1 @@
+EBUILD bpython-9999.ebuild 752 RMD160 59c786986be1aa6f021a2d7350f19a145691d2d4 SHA1 a5f132b9963445cc8f30e0c3eb8b105e25e367c8 SHA256 93a45ff94f4738222b03fe0e1145fb1a96b7c97240472aa7736bc71898bae3c2
diff --git a/dev-python/bpython/bpython-9999.ebuild b/dev-python/bpython/bpython-9999.ebuild
new file mode 100644
index 0000000..19d0906
--- /dev/null
+++ b/dev-python/bpython/bpython-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils git
+
+EGIT_REPO_URI="git://github.com/bobf/bpython.git"
+
+DESCRIPTION="A fancy interface to the Python interpreter for Unix-like operating systems."
+HOMEPAGE="http://www.noiseforfree.com/bpython/"
+SRC_URI=""
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-python/pygments
+ >=dev-python/pyparsing-1.4.11"
+
+DOCS="sample-rc"
+
+pkg_setup()
+{
+ if ! built_with_use dev-lang/python ncurses; then
+ echo
+ eerror "dev-lang/python needs to be built with ncurses support."
+ eerror "Please re-emerge python with the ncurses use flag set."
+ die "Missing ncurses flag for dev-lang/python"
+ fi
+}