summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2008-08-01 22:54:56 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2008-08-01 22:54:56 +0200
commitc8345f095c048f39b6875a6b0f204c8d20b16d14 (patch)
tree19fffccd1786ce9444e4356811915a3586f2ea2f /dev-python
parenta0be121843ac8e22af4d1ab9be30e5d89df924a9 (diff)
downloadoverlay-c8345f095c048f39b6875a6b0f204c8d20b16d14.tar.gz
overlay-c8345f095c048f39b6875a6b0f204c8d20b16d14.tar.bz2
overlay-c8345f095c048f39b6875a6b0f204c8d20b16d14.zip
Added htmlgen
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/htmlgen/Manifest2
-rw-r--r--dev-python/htmlgen/htmlgen-2.2.2.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/htmlgen/Manifest b/dev-python/htmlgen/Manifest
new file mode 100644
index 0000000..dbf5225
--- /dev/null
+++ b/dev-python/htmlgen/Manifest
@@ -0,0 +1,2 @@
+DIST HTMLgen.tgz 316415 RMD160 bb32b2822f7ce8e49eb42853aff330429df073de SHA1 a34b9c1f9cf5536a548c66522213ac9fee1b43cd SHA256 f3b39b4b07b5dd318780ad0e9b8b3c524a54138537697dd7966223f314d2177d
+EBUILD htmlgen-2.2.2.ebuild 1516 RMD160 23d34cfafc916ee6af4c6be9eb8284e9cf15362f SHA1 72b91ee06e87b3cec2fd03358ebd3fa6095bf718 SHA256 7af044810e8b84ebd19fe274eda45b6dff286095d7d2112f9c48a2738bb0e064
diff --git a/dev-python/htmlgen/htmlgen-2.2.2.ebuild b/dev-python/htmlgen/htmlgen-2.2.2.ebuild
new file mode 100644
index 0000000..d14e4c9
--- /dev/null
+++ b/dev-python/htmlgen/htmlgen-2.2.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/htmlgen/htmlgen-2.2.2.ebuild,v 1.12 2006/07/12 15:39:25 agriffis Exp $
+
+inherit python
+
+MY_P="HTMLgen"
+DESCRIPTION="HTMLgen - Python modules for the generation of HTML documents"
+HOMEPAGE="http://starship.python.net/crew/friedrich/HTMLgen/html/main.html"
+SRC_URI="http://starship.python.net/crew/friedrich/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="ia64 ppc x86"
+IUSE="doc"
+
+DEPEND="virtual/python
+ dev-python/imaging"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ # nothing to do
+ :
+}
+
+src_install() {
+ # doing this manually because their build scripts suck
+ local files="HTMLgen.py HTMLcolors.py HTMLutil.py HTMLcalendar.py \
+ barchart.py colorcube.py imgsize.py NavLinks.py Formtools.py \
+ ImageH.py ImageFileH.py ImagePaletteH.py GifImagePluginH.py \
+ JpegImagePluginH.py PngImagePluginH.py"
+
+ touch __init__.py
+
+ insinto $(get_python_sitedir)/htmlgen
+ doins $files __init__.py || die "doins failed"
+
+ if use doc; then
+ # fix the image locations in the docs
+ sed -i -e "s;../image/;image/;g" html/* || die "sed failed"
+ dohtml html/*
+ dohtml -r image
+ fi
+ dodoc README
+}
+
+pkg_postinst() {
+ python_mod_optimize $(get_python_sitedir)/htmlgen
+
+ ewarn "htmlgen now resides in its own subdirectory"
+ ewarn "so you need to do \"from htmlgen import HTMLgen\" instead of \"import HTMLgen\""
+}
+
+pkg_postrm () {
+ python_mod_cleanup $(get_python_sitedir)/htmlgen
+}