summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2011-10-16 23:24:08 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2011-10-16 23:24:08 +0200
commitacb35ad65072d1705b86b48f628f8e833e4a39a9 (patch)
tree5a729036d3c3afa29cf43a7d9b1374461a6a2135
parent29533bff5023fe229f22e23664b2b8749df17754 (diff)
downloadoverlay-acb35ad65072d1705b86b48f628f8e833e4a39a9.tar.gz
overlay-acb35ad65072d1705b86b48f628f8e833e4a39a9.tar.bz2
overlay-acb35ad65072d1705b86b48f628f8e833e4a39a9.zip
Fix dovecot's vacation handler
-rw-r--r--net-mail/dovecot/Manifest7
-rw-r--r--net-mail/dovecot/dovecot-2.0.13.ebuild282
-rw-r--r--net-mail/dovecot/files/dovecot-1.2.init61
-rw-r--r--net-mail/dovecot/files/dovecot-2.0.12-sdbox.patch17
-rw-r--r--net-mail/dovecot/files/dovecot.init-r258
-rw-r--r--net-mail/dovecot/files/pigeonhole-fix-vacation-handle.patch140
6 files changed, 565 insertions, 0 deletions
diff --git a/net-mail/dovecot/Manifest b/net-mail/dovecot/Manifest
new file mode 100644
index 0000000..5e6773d
--- /dev/null
+++ b/net-mail/dovecot/Manifest
@@ -0,0 +1,7 @@
+AUX dovecot-1.2.init 1701 RMD160 89cdc58d6ad9ac41f8946fabf3c80e0b9f4b61ea SHA1 9cbf10e9d1997ad3703ee1ae37edbcfad6f16b79 SHA256 44b308537454362b00f8ab87257c4a0d8eb5a183452ca2e3487f74b642fac8e0
+AUX dovecot-2.0.12-sdbox.patch 545 RMD160 92b9d80e3cd1c2f915d4c4fcc751a8267c9cf619 SHA1 6046b2a8076b478deab2003142b31020f875fb5e SHA256 f4f70d4ff9453e5ec3246b3bef27adf101de84ce2d1dcff50577ff79b22d9441
+AUX dovecot.init-r2 1599 RMD160 25ef78d824139012d9df98d3f7f0da420a84c061 SHA1 c796be3c8d1b97a3abbf5026dedeab6750187b3b SHA256 208dd8f1f29a09aa306ea7f89aedf11468b187141f2c39b7c148e6007c8de4be
+AUX pigeonhole-fix-vacation-handle.patch 4686 RMD160 3c33e09b72a3115d00cbfbe3fc59d373f23aecea SHA1 8842207b84e4ee8711777709b7047bde407549a8 SHA256 ed6e4b28234e7a1f44033d4ad33a611a6113915b40064f90af0d9c10c051e2d9
+DIST dovecot-2.0-pigeonhole-0.2.4.tar.gz 1230408 RMD160 61cf4209210f56d033586d779eca31f7433dbf62 SHA1 43e1ab3f4435765c6ecf14594c8fa41a3a046bb2 SHA256 9a19dc50bb006de6ee0aec9d3c46e6ee5bc904ca823e6dd9636a2eec5378980e
+DIST dovecot-2.0.13.tar.gz 3272542 RMD160 2c0edd03aba7935e6db18af1384a26bf0b5b432e SHA1 31d556bd1659fb10e5edb45bab8951911151bbfb SHA256 2b512263ec05bbd74cde5c697ad12250d9268eba1c8ce4a8144adea69308675d
+EBUILD dovecot-2.0.13.ebuild 9074 RMD160 73ccc466d7e96f5df10439a14fc8016a4f2c5f58 SHA1 92fbf9872a5eb429f1cf34ad1143f6524e35fa37 SHA256 0097a957bb0cf0139664a92bfed76226bc6551e6b1f1b0b09a4b717eac9960c0
diff --git a/net-mail/dovecot/dovecot-2.0.13.ebuild b/net-mail/dovecot/dovecot-2.0.13.ebuild
new file mode 100644
index 0000000..9e8aed0
--- /dev/null
+++ b/net-mail/dovecot/dovecot-2.0.13.ebuild
@@ -0,0 +1,282 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-2.0.13.ebuild,v 1.10 2011/09/10 16:45:51 armin76 Exp $
+
+EAPI="3"
+
+inherit eutils versionator ssl-cert
+
+MY_P="${P/_/.}"
+major_minor="$( get_version_component_range 1-2 )"
+sieve_version="0.2.4"
+SRC_URI="http://dovecot.org/releases/${major_minor}/${MY_P}.tar.gz
+ sieve? (
+ http://www.rename-it.nl/dovecot/${major_minor}/dovecot-${major_minor}-pigeonhole-${sieve_version}.tar.gz
+ )
+ managesieve? (
+ http://www.rename-it.nl/dovecot/${major_minor}/dovecot-${major_minor}-pigeonhole-${sieve_version}.tar.gz
+ ) "
+DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
+HOMEPAGE="http://www.dovecot.org/"
+
+SLOT="0"
+LICENSE="LGPL-2.1 MIT"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+
+IUSE="bzip2 caps cydir sdbox doc ipv6 kerberos ldap +maildir managesieve mbox mdbox mysql pam postgres sieve sqlite +ssl suid vpopmail zlib"
+
+DEPEND="caps? ( sys-libs/libcap )
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap )
+ mysql? ( virtual/mysql )
+ pam? ( virtual/pam )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( dev-db/sqlite )
+ ssl? ( dev-libs/openssl )
+ vpopmail? ( net-mail/vpopmail )
+ virtual/libiconv"
+
+RDEPEND="${DEPEND}
+ >=net-mail/mailbase-0.00-r8"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if use managesieve && ! use sieve; then
+ ewarn "managesieve USE flag selected but sieve USE flag unselected"
+ ewarn "sieve USE flag will be turned on"
+ fi
+
+ # Add user and group for login process (same as for fedora/redhat)
+ # default internal user
+ enewgroup dovecot 97
+ enewuser dovecot 97 -1 /dev/null dovecot
+ # add "mail" group for suid'ing. Better security isolation.
+ if use suid; then
+ enewgroup mail
+ fi
+ # default login user
+ enewuser dovenull -1 -1 /dev/null
+}
+
+src_prepare() {
+ cd "${WORKDIR}/dovecot-${major_minor}-pigeonhole-${sieve_version}"
+ epatch "${FILESDIR}/pigeonhole-fix-vacation-handle.patch"
+}
+
+src_configure() {
+ local conf=""
+
+ if use postgres || use mysql || use sqlite; then
+ conf="${conf} --with-sql"
+ fi
+
+ local storages=""
+ for storage in cydir sdbox mdbox maildir mbox; do
+ use ${storage} && storages="${storage} ${storages}"
+ done
+ [ "${storages}" ] || storages="maildir"
+
+ # turn valgrind tests off. Bug #340791
+ VALGRIND=no econf \
+ --localstatedir="${EPREFIX}/var" \
+ --with-moduledir="${EPREFIX}/usr/$(get_libdir)/dovecot" \
+ $( use_with bzip2 bzlib ) \
+ $( use_with caps libcap ) \
+ $( use_with kerberos gssapi ) \
+ $( use_with ldap ) \
+ $( use_with mysql ) \
+ $( use_with pam ) \
+ $( use_with postgres pgsql ) \
+ $( use_with sqlite ) \
+ $( use_with ssl ) \
+ $( use_with vpopmail ) \
+ $( use_with zlib ) \
+ --with-storages="${storages}" \
+ --disable-rpath \
+ --without-systemdsystemunitdir \
+ ${conf}
+
+ if use sieve || use managesieve ; then
+ # The sieve plugin needs this file to be build to determine the plugin
+ # directory and the list of libraries to link to.
+ emake dovecot-config || die "emake dovecot-config failed"
+ cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+ econf \
+ --localstatedir="${EPREFIX}/var" \
+ --enable-shared \
+ --with-dovecot="../${MY_P}" \
+ $( use_with managesieve )
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "make failed"
+
+ if use sieve || use managesieve ; then
+ cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "make sieve failed"
+ fi
+}
+
+src_test() {
+ default_src_test
+ if use sieve || use managesieve ; then
+ cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+ default_src_test
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${ED}" install || die "make install failed"
+
+ # insecure:
+ # use suid && fperms u+s /usr/libexec/dovecot/deliver
+ # better:
+ if use suid;then
+ einfo "Changing perms to allow deliver to be suided"
+ fowners root:mail "${ED}"/usr/libexec/dovecot/deliver
+ fperms 4750 "${ED}"/usr/libexec/dovecot/deliver
+ fi
+
+ newinitd "${FILESDIR}"/dovecot.init-r2 dovecot
+
+ rm -rf "${ED}"/usr/share/doc/dovecot
+
+ dodoc AUTHORS NEWS README TODO || die "basic dodoc failed"
+ dodoc doc/*.{txt,cnf,xml,sh} || die "dodoc doc failed"
+ docinto example-config
+ dodoc doc/example-config/*.{conf,ext} || die "dodoc example failed"
+ docinto example-config/conf.d
+ dodoc doc/example-config/conf.d/*.{conf,ext} || die "dodoc conf.d failed"
+ docinto wiki
+ dodoc doc/wiki/* || die "dodoc wiki failed"
+ doman doc/man/*.{1,7}
+
+ # Create the dovecot.conf file from the dovecot-example.conf file that
+ # the dovecot folks nicely left for us....
+ local conf="${ED}/etc/dovecot/dovecot.conf"
+ local confd="${ED}/etc/dovecot/conf.d"
+
+ insinto /etc/dovecot
+ doins doc/example-config/*.{conf,ext}
+ insinto /etc/dovecot/conf.d
+ doins doc/example-config/conf.d/*.{conf,ext}
+ fperms 0600 "${EPREFIX}"/etc/dovecot/dovecot-{ldap,sql}.conf.ext
+ sed -i -e "s:/usr/share/doc/dovecot/:/usr/share/doc/${PF}/:" \
+ "${confd}/../README" || die "sed failed"
+
+ # .maildir is the Gentoo default
+ local mail_location="maildir:~/.maildir"
+ if ! use maildir; then
+ if use mbox; then
+ mail_location="mbox:/var/spool/mail/%u:INDEX=/var/dovecot/%u"
+ keepdir /var/dovecot
+ sed -i -e 's|#mail_privileged_group =|mail_privileged_group = mail|' \
+ "${confd}/10-mail.conf" || die "sed failed"
+ elif use sdbox ; then
+ mail_location="sdbox:~/.sdbox"
+ elif use mdbox ; then
+ mail_location="mdbox:~/.mdbox"
+ fi
+ fi
+ sed -i -e \
+ "s|#mail_location =|mail_location = ${mail_location}|" \
+ "${confd}/10-mail.conf" \
+ || die "failed to update mail location settings in 10-mail.conf"
+
+ # We're using pam files (imap and pop3) provided by mailbase
+ if use pam; then
+ sed -i -e '/driver = pam/,/^[ \t]*}/ s|#args = dovecot|args = "\*"|' \
+ "${confd}/auth-system.conf.ext" \
+ || die "failed to update PAM settings in auth-system.conf.ext"
+ # mailbase does not provide a sieve pam file
+ use managesieve && dosym imap /etc/pam.d/sieve
+ sed -i -e \
+ 's/#!include auth-system.conf.ext/!include auth-system.conf.ext/' \
+ "${confd}/10-auth.conf" \
+ || die "failed to update PAM settings in 10-auth.conf"
+ fi
+
+ # Disable ipv6 if necessary
+ if ! use ipv6; then
+ sed -i -e 's/^#listen = \*, ::/listen = \*/g' "${conf}" \
+ || die "failed to update listen settings in dovecot.conf"
+ fi
+
+ # Update ssl cert locations
+ if use ssl; then
+ sed -i -e 's:^#ssl = yes:ssl = yes:' "${confd}/10-ssl.conf" \
+ || die "ssl conf failed"
+ sed -i -e 's:^ssl_cert =.*:ssl_cert = </etc/ssl/dovecot/server.pem:' \
+ -e 's:^ssl_key =.*:ssl_key = </etc/ssl/dovecot/server.key:' \
+ "${confd}/10-ssl.conf" || die "failed to update SSL settings in 10-ssl.conf"
+ fi
+
+ # Install SQL configuration
+ if use mysql || use postgres; then
+ sed -i -e \
+ 's/#!include auth-sql.conf.ext/!include auth-sql.conf.ext/' \
+ "${confd}/10-auth.conf" || die "failed to update SQL settings in \
+ 10-auth.conf"
+ fi
+
+ # Install LDAP configuration
+ if use ldap; then
+ sed -i -e \
+ 's/#!include auth-ldap.conf.ext/!include auth-ldap.conf.ext/' \
+ "${confd}/10-auth.conf" \
+ || die "failed to update ldap settings in 10-auth.conf"
+ fi
+
+ if use vpopmail; then
+ sed -i -e \
+ 's/#!include auth-vpopmail.conf.ext/!include auth-vpopmail.conf.ext/' \
+ "${confd}/10-auth.conf" \
+ || die "failed to update vpopmail settings in 10-auth.conf"
+ fi
+
+ if use sieve || use managesieve ; then
+ cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+ emake DESTDIR="${ED}" install || die "make install failed (sieve)"
+ sed -i -e \
+ 's/^[[:space:]]*#mail_plugins = $mail_plugins/mail_plugins = sieve/' "${confd}/15-lda.conf" \
+ || die "failed to update sieve settings in 15-lda.conf"
+ rm -rf "${ED}"/usr/share/doc/dovecot
+ dodoc doc/*.txt
+ docinto example-config/conf.d
+ dodoc doc/example-config/conf.d/*.conf
+ insinto /etc/dovecot/conf.d
+ doins doc/example-config/conf.d/90-sieve.conf
+ use managesieve && doins doc/example-config/conf.d/20-managesieve.conf
+ docinto sieve/rfc
+ dodoc doc/rfc/*.txt
+ docinto sieve/devel
+ dodoc doc/devel/DESIGN
+ doman doc/man/*.{1,7}
+ fi
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-2" ; then
+ elog "There are a lot of changes in configuration files in dovecot-2.0."
+ elog "Please read http://wiki.dovecot.org/Upgrading and"
+ elog "check the conf files in ${ROOT}etc/dovecot."
+ elog "You can also run doveconf -n before running etc-update or"
+ elog "dispatch-conf to get an idea about what needs to be changed."
+ ewarn "\nDo NOT {re}start dovecot without checking your conf files"
+ ewarn "and making the necessary changes.\n"
+ fi
+}
+
+pkg_postinst() {
+ if use ssl; then
+ # Let's not make a new certificate if we already have one
+ if ! [[ -e "${ROOT}"/etc/ssl/dovecot/server.pem && \
+ -e "${ROOT}"/etc/ssl/dovecot/server.key ]]; then
+ einfo "Creating SSL certificate"
+ SSL_ORGANIZATION="${SSL_ORGANIZATION:-Dovecot IMAP Server}"
+ install_cert /etc/ssl/dovecot/server
+ fi
+ fi
+}
diff --git a/net-mail/dovecot/files/dovecot-1.2.init b/net-mail/dovecot/files/dovecot-1.2.init
new file mode 100644
index 0000000..b9dd672
--- /dev/null
+++ b/net-mail/dovecot/files/dovecot-1.2.init
@@ -0,0 +1,61 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/files/dovecot-1.2.init,v 1.2 2011/08/05 07:05:46 eras Exp $
+
+opts="${opts} reload"
+
+depend() {
+ need localmount net
+ before postfix
+ after bootmisc ldap mysql ntp-client ntpd postgresql saslauthd slapd
+ use logger
+}
+
+checkconfig() {
+ DOVECOT_INSTANCE=${SVCNAME##*.}
+ if [ -n "${DOVECOT_INSTANCE}" -a "${SVCNAME}" != "dovecot" ]; then
+ DOVECOT_CONF=/etc/dovecot/dovecot.${DOVECOT_INSTANCE}.conf
+ else
+ DOVECOT_CONF=/etc/dovecot/dovecot.conf
+ fi
+ if [ ! -e ${DOVECOT_CONF} ]; then
+ eerror "You will need an ${DOVECOT_CONF} first"
+ return 1
+ fi
+ if [ -x /usr/sbin/dovecot ]; then
+ DOVECOT_BASEDIR=$(/usr/sbin/dovecot -c ${DOVECOT_CONF} -a | grep '^base_dir: ' | sed 's/^base_dir: //')
+ else
+ eerror "dovecot not executable"
+ return 1
+ fi
+ DOVECOT_BASEDIR=${DOVECOT_BASEDIR:-/var/run/dovecot}
+ DOVECOT_PIDFILE=${DOVECOT_BASEDIR}/master.pid
+ if [ ! -d "${DOVECOT_BASEDIR}" ]; then
+ install -d -o root -g root -m 0755 "${DOVECOT_BASEDIR}"
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --exec /usr/sbin/dovecot \
+ --pidfile "${DOVECOT_PIDFILE}" -- -c "${DOVECOT_CONF}"
+ eend $?
+}
+
+stop() {
+ checkconfig || return 1
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --exec /usr/sbin/dovecot \
+ --pidfile "${DOVECOT_PIDFILE}"
+ eend $?
+}
+
+reload() {
+ checkconfig || return 1
+ ebegin "Reloading ${SVCNAME} configs and restarting auth/login processes"
+ start-stop-daemon --signal HUP --exec /usr/sbin/dovecot \
+ --pidfile "${DOVECOT_PIDFILE}"
+ eend $?
+}
diff --git a/net-mail/dovecot/files/dovecot-2.0.12-sdbox.patch b/net-mail/dovecot/files/dovecot-2.0.12-sdbox.patch
new file mode 100644
index 0000000..ad16cf3
--- /dev/null
+++ b/net-mail/dovecot/files/dovecot-2.0.12-sdbox.patch
@@ -0,0 +1,17 @@
+
+diff -r d4945c93c33b -r 663528c5c799 src/lib-storage/index/dbox-single/sdbox-storage.c
+--- a/src/lib-storage/index/dbox-single/sdbox-storage.c Tue Apr 12 18:38:50 2011 +0300
++++ b/src/lib-storage/index/dbox-single/sdbox-storage.c Sat Apr 30 15:55:08 2011 +0300
+@@ -118,6 +118,8 @@
+ mail_index_update_header_ext(trans, mbox->hdr_ext_id, 0,
+ &new_hdr, sizeof(new_hdr));
+ }
++ memcpy(mbox->mailbox_guid, new_hdr.mailbox_guid,
++ sizeof(mbox->mailbox_guid));
+ }
+
+ static int sdbox_mailbox_create_indexes(struct mailbox *box,
+
+
+
+
diff --git a/net-mail/dovecot/files/dovecot.init-r2 b/net-mail/dovecot/files/dovecot.init-r2
new file mode 100644
index 0000000..21447fe
--- /dev/null
+++ b/net-mail/dovecot/files/dovecot.init-r2
@@ -0,0 +1,58 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/files/dovecot.init-r2,v 1.4 2011/08/05 07:05:46 eras Exp $
+
+opts="${opts} reload"
+
+depend() {
+ need localmount net
+ before postfix
+ after bootmisc ldap mysql ntp-client ntpd postgresql saslauthd slapd
+ use logger
+}
+
+checkconfig() {
+ DOVECOT_INSTANCE=${SVCNAME##*.}
+ if [ -n "${DOVECOT_INSTANCE}" -a "${SVCNAME}" != "dovecot" ]; then
+ DOVECOT_CONF=/etc/dovecot/dovecot.${DOVECOT_INSTANCE}.conf
+ else
+ DOVECOT_CONF=/etc/dovecot/dovecot.conf
+ fi
+ if [ ! -e ${DOVECOT_CONF} ]; then
+ eerror "You will need an ${DOVECOT_CONF} first"
+ return 1
+ fi
+ if [ -x /usr/sbin/dovecot ]; then
+ DOVECOT_BASEDIR=$(/usr/sbin/dovecot -c ${DOVECOT_CONF} -a | grep '^base_dir = ' | sed 's/^base_dir = //')
+ else
+ eerror "dovecot not executable"
+ return 1
+ fi
+ DOVECOT_BASEDIR=${DOVECOT_BASEDIR:-/var/run/dovecot}
+ DOVECOT_PIDFILE=${DOVECOT_BASEDIR}/master.pid
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --exec /usr/sbin/dovecot \
+ --pidfile "${DOVECOT_PIDFILE}" -- -c "${DOVECOT_CONF}"
+ eend $?
+}
+
+stop() {
+ checkconfig || return 1
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --exec /usr/sbin/dovecot \
+ --pidfile "${DOVECOT_PIDFILE}"
+ eend $?
+}
+
+reload() {
+ checkconfig || return 1
+ ebegin "Reloading ${SVCNAME} configs and restarting auth/login processes"
+ start-stop-daemon --signal HUP --exec /usr/sbin/dovecot \
+ --pidfile "${DOVECOT_PIDFILE}"
+ eend $?
+}
diff --git a/net-mail/dovecot/files/pigeonhole-fix-vacation-handle.patch b/net-mail/dovecot/files/pigeonhole-fix-vacation-handle.patch
new file mode 100644
index 0000000..744b67e
--- /dev/null
+++ b/net-mail/dovecot/files/pigeonhole-fix-vacation-handle.patch
@@ -0,0 +1,140 @@
+
+--- a/src/lib-sieve/plugins/vacation/cmd-vacation.c Tue Aug 02 17:50:15 2011 +0200
++++ b/src/lib-sieve/plugins/vacation/cmd-vacation.c Wed Sep 21 00:55:58 2011 +0200
+@@ -231,7 +231,7 @@
+
+ bool mime;
+
+- string_t *handle;
++ struct sieve_ast_argument *handle_arg;
+ };
+
+ /*
+@@ -348,10 +348,10 @@
+ *arg = sieve_ast_argument_next(*arg);
+
+ } else if ( sieve_argument_is(tag, vacation_handle_tag) ) {
+- ctx_data->handle = sieve_ast_argument_str(*arg);
+-
++ ctx_data->handle_arg = *arg;
++
+ /* Detach optional argument (emitted as mandatory) */
+- *arg = sieve_ast_arguments_detach(*arg,1);
++ *arg = sieve_ast_arguments_detach(*arg, 1);
+ }
+
+ return TRUE;
+@@ -468,34 +468,48 @@
+ return FALSE;
+
+ /* Construct handle if not set explicitly */
+- if ( ctx_data->handle == NULL ) {
+- string_t *reason = sieve_ast_argument_str(arg);
+- unsigned int size = str_len(reason);
++ if ( ctx_data->handle_arg == NULL ) {
++ T_BEGIN {
++ string_t *handle;
++ string_t *reason = sieve_ast_argument_str(arg);
++ unsigned int size = str_len(reason);
+
+- /* Precalculate the size of it all */
+- size += ctx_data->subject == NULL ?
+- sizeof(_handle_empty_subject) - 1 : str_len(ctx_data->subject);
+- size += ctx_data->from == NULL ?
+- sizeof(_handle_empty_from) - 1 : str_len(ctx_data->from);
+- size += ctx_data->mime ?
+- sizeof(_handle_mime_enabled) - 1 : sizeof(_handle_mime_disabled) - 1;
++ /* Precalculate the size of it all */
++ size += ctx_data->subject == NULL ?
++ sizeof(_handle_empty_subject) - 1 : str_len(ctx_data->subject);
++ size += ctx_data->from == NULL ?
++ sizeof(_handle_empty_from) - 1 : str_len(ctx_data->from);
++ size += ctx_data->mime ?
++ sizeof(_handle_mime_enabled) - 1 : sizeof(_handle_mime_disabled) - 1;
+
+- /* Construct the string */
+- ctx_data->handle = str_new(sieve_command_pool(cmd), size);
+- str_append_str(ctx_data->handle, reason);
++ /* Construct the string */
++ handle = t_str_new(size);
++ str_append_str(handle, reason);
+
+- if ( ctx_data->subject != NULL )
+- str_append_str(ctx_data->handle, ctx_data->subject);
+- else
+- str_append(ctx_data->handle, _handle_empty_subject);
++ if ( ctx_data->subject != NULL )
++ str_append_str(handle, ctx_data->subject);
++ else
++ str_append(handle, _handle_empty_subject);
+
+- if ( ctx_data->from != NULL )
+- str_append_str(ctx_data->handle, ctx_data->from);
+- else
+- str_append(ctx_data->handle, _handle_empty_from);
++ if ( ctx_data->from != NULL )
++ str_append_str(handle, ctx_data->from);
++ else
++ str_append(handle, _handle_empty_from);
+
+- str_append(ctx_data->handle,
+- ctx_data->mime ? _handle_mime_enabled : _handle_mime_disabled );
++ str_append(handle,
++ ctx_data->mime ? _handle_mime_enabled : _handle_mime_disabled );
++
++ /* Create positional handle argument */
++ ctx_data->handle_arg = sieve_ast_argument_string_create
++ (cmd->ast_node, handle, sieve_ast_node_line(cmd->ast_node));
++ } T_END;
++
++ if ( !sieve_validator_argument_activate
++ (valdtr, cmd, ctx_data->handle_arg, TRUE) )
++ return FALSE;
++ } else {
++ /* Attach explicit handle argument as positional */
++ (void)sieve_ast_argument_attach(cmd->ast_node, ctx_data->handle_arg);
+ }
+
+ return TRUE;
+@@ -507,18 +521,12 @@
+
+ static bool cmd_vacation_generate
+ (const struct sieve_codegen_env *cgenv, struct sieve_command *cmd)
+-{
+- struct cmd_vacation_context_data *ctx_data =
+- (struct cmd_vacation_context_data *) cmd->data;
+-
++{
+ sieve_operation_emit(cgenv->sblock, cmd->ext, &vacation_operation);
+
+ /* Generate arguments */
+ if ( !sieve_generate_arguments(cgenv, cmd, NULL) )
+ return FALSE;
+-
+- /* FIXME: this will not allow the handle to be a variable */
+- sieve_opr_string_emit(cgenv->sblock, ctx_data->handle);
+
+ return TRUE;
+ }
+@@ -779,13 +787,13 @@
+ (struct act_vacation_context *) action->context;
+
+ sieve_result_action_printf( rpenv, "send vacation message:");
+- sieve_result_printf(rpenv, " => seconds : %d\n", ctx->seconds);
++ sieve_result_printf(rpenv, " => seconds : %d\n", ctx->seconds);
+ if ( ctx->subject != NULL )
+- sieve_result_printf(rpenv, " => subject: %s\n", ctx->subject);
++ sieve_result_printf(rpenv, " => subject : %s\n", ctx->subject);
+ if ( ctx->from != NULL )
+- sieve_result_printf(rpenv, " => from : %s\n", ctx->from);
++ sieve_result_printf(rpenv, " => from : %s\n", ctx->from);
+ if ( ctx->handle != NULL )
+- sieve_result_printf(rpenv, " => handle : %s\n", ctx->handle);
++ sieve_result_printf(rpenv, " => handle : %s\n", ctx->handle);
+ sieve_result_printf(rpenv, "\nSTART MESSAGE\n%s\nEND MESSAGE\n", ctx->reason);
+ }
+
+
+
+
+