summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené Neumann <rene.neumann@in.tum.de>2011-08-11 19:41:49 +0200
committerRené Neumann <rene.neumann@in.tum.de>2011-08-11 19:41:49 +0200
commit955b5666a61e71ee40d363e3776722f5673c03e1 (patch)
tree4a6e6d8153883bd26bd1f5aaa84a1e166878ba7f
parent649ed3773a9fef8712733fbdcc9d09a5bae62f99 (diff)
parent7c7f543b79bc9eb19d8d120ec1b4f2dfeb73b6be (diff)
downloadoverlay-955b5666a61e71ee40d363e3776722f5673c03e1.tar.gz
overlay-955b5666a61e71ee40d363e3776722f5673c03e1.tar.bz2
overlay-955b5666a61e71ee40d363e3776722f5673c03e1.zip
Merge branch 'master' of necoro.eu:overlay
-rw-r--r--app-office/radicale/Manifest5
-rw-r--r--app-office/radicale/files/logging60
-rwxr-xr-xapp-office/radicale/files/radicale.fcgi36
-rwxr-xr-xapp-office/radicale/files/radicale.wsgi26
-rw-r--r--app-office/radicale/radicale-0.6.ebuild60
-rw-r--r--profiles/package.mask1
6 files changed, 188 insertions, 0 deletions
diff --git a/app-office/radicale/Manifest b/app-office/radicale/Manifest
index b9134ab..c640133 100644
--- a/app-office/radicale/Manifest
+++ b/app-office/radicale/Manifest
@@ -1,2 +1,7 @@
+AUX logging 1034 RMD160 a3edc69f3bd9b111e02903cc5f49169323933f68 SHA1 d9c2f56de2b0501741250da78ba1689ac1fbd3cc SHA256 095d292d26491c72e401c68586f6013ec822b04fa919439f401f715e6ba5fccf
+AUX radicale.fcgi 1116 RMD160 01f7d5e69ae1e194fcee1ed96aba2218586b6079 SHA1 9095612ced9a0d22112313aa44081b951c980549 SHA256 9e00346fae03658f17ef47c94c6ad50116b750d2eef435152b621542895e75d8
AUX radicale.init.d 550 RMD160 f1f6aa919952b744900c781b8d6cd9283bc44534 SHA1 3c2043b9f2680b14969bd7f3727e3df85c7f9c48 SHA256 1b28de6c1bc2c6119eb654622713fdd2c16d89105940c6b55d2bc081fbb2fd2c
+AUX radicale.wsgi 888 RMD160 32965394ef97e3ee8ba958e6aaa62a8d62a69c9b SHA1 56cd1d79321735d5d2f5ec8ecc7404708d361d4c SHA256 cffe36a531d7f897e3822c059c4b0cb7fd8cd2cf0a659e4bddb39abed8101ca2
+DIST Radicale-0.6.tar.gz 29903 RMD160 343637edab81ef7a4804020f16b28448081af084 SHA1 ffe51253cc6cf3bc9f28057b55e64dd95147fa30 SHA256 5798c80a842e023dcdf4829fa47f74d500dfa71264c193b24fd5397407efbf5c
+EBUILD radicale-0.6.ebuild 1348 RMD160 22d94aac5fdcc671103aa023ed40e47dc236482d SHA1 d6a460db4c4a55520fd74b8d7981dcdb8eac9bc9 SHA256 92b3b7c5465fe05ee1d723dcfd56977fc11290b8290bfea54c3b70b9c1504b93
EBUILD radicale-9999.ebuild 792 RMD160 5239fd36cee932180729089609dcc94d1fed2653 SHA1 8988ea9bb90c439553e4fac74579c9cfd28a0fb3 SHA256 cad0db601c86dbe05299a558591cd23e885aa2b0faac700fee04fdae549f2d66
diff --git a/app-office/radicale/files/logging b/app-office/radicale/files/logging
new file mode 100644
index 0000000..f4efb88
--- /dev/null
+++ b/app-office/radicale/files/logging
@@ -0,0 +1,60 @@
+# -*- mode: conf -*-
+# vim:ft=cfg
+
+# Logging config file for Radicale - A simple calendar server
+#
+# The default path for this file is /etc/radicale/logging
+# This can be changed in the configuration file
+#
+# Other handlers are available. For more information, see:
+# http://docs.python.org/library/logging.config.html
+
+
+# Loggers, handlers and formatters keys
+
+[loggers]
+# Loggers names, main configuration slots
+keys = root
+
+[handlers]
+# Logging handlers, defining logging output methods
+keys = console,file
+
+[formatters]
+# Logging formatters
+keys = simple,full
+
+
+# Loggers
+
+[logger_root]
+# Root logger
+level = DEBUG
+handlers = console,file
+
+
+# Handlers
+
+[handler_console]
+# Console handler
+class = StreamHandler
+level = INFO
+args = (sys.stdout,)
+formatter = simple
+
+[handler_file]
+# File handler
+class = FileHandler
+args = ('/var/log/radicale',)
+formatter = full
+
+
+# Formatters
+
+[formatter_simple]
+# Simple output format
+format = %(message)s
+
+[formatter_full]
+# Full output format
+format = %(asctime)s - %(levelname)s: %(message)s
diff --git a/app-office/radicale/files/radicale.fcgi b/app-office/radicale/files/radicale.fcgi
new file mode 100755
index 0000000..e284450
--- /dev/null
+++ b/app-office/radicale/files/radicale.fcgi
@@ -0,0 +1,36 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+#
+# This file is part of Radicale Server - Calendar Server
+# Copyright © 2011 Guillaume Ayoub
+#
+# This library is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Radicale. If not, see <http://www.gnu.org/licenses/>.
+
+"""
+Radicale FastCGI Example.
+
+Launch a Radicale FastCGI server according to configuration.
+
+"""
+
+from flup.server.fcgi import WSGIServer
+import radicale
+
+
+radicale.log.start()
+radicale.log.LOGGER.info("Starting Radicale FastCGI server")
+
+WSGIServer(radicale.Application()).run()
+
+radicale.log.LOGGER.info("Stopping Radicale FastCGI server")
diff --git a/app-office/radicale/files/radicale.wsgi b/app-office/radicale/files/radicale.wsgi
new file mode 100755
index 0000000..3f0d0dc
--- /dev/null
+++ b/app-office/radicale/files/radicale.wsgi
@@ -0,0 +1,26 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+#
+# This file is part of Radicale Server - Calendar Server
+# Copyright © 2011 Guillaume Ayoub
+#
+# This library is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Radicale. If not, see <http://www.gnu.org/licenses/>.
+
+"""
+Radicale WSGI file (mod_wsgi and uWSGI compliant).
+
+"""
+
+import radicale
+application = radicale.Application()
diff --git a/app-office/radicale/radicale-0.6.ebuild b/app-office/radicale/radicale-0.6.ebuild
new file mode 100644
index 0000000..58c643d
--- /dev/null
+++ b/app-office/radicale/radicale-0.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+PYTHON_DEPEND="*:2.6"
+SUPPORT_PYTHON_ABIS=1
+
+inherit distutils
+
+MY_P="${PN/r/R}-${PV}"
+
+DESCRIPTION="A simple CalDAV calendar server"
+HOMEPAGE="http://www.radicale.org/"
+SRC_URI="http://www.radicale.org/src/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="ldap fastcgi ssl"
+
+# the '>=' goes ok, as radicale supports _all_ other python version
+# this includes all 3.* versions
+DEPEND="ssl? ( >=dev-lang/python-2.6.6[ssl] )
+ ldap? ( dev-python/python-ldap )
+ fastcgi? ( dev-python/flup )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ distutils_src_prepare
+
+ sed -i -e "s/htpasswd_encoding/encoding/" ${S}/radicale/acl/htpasswd.py || die
+}
+
+src_install() {
+ distutils_src_install
+
+ # init file
+ newinitd "${FILESDIR}"/radicale.init.d radicale || die
+
+ # config file
+ insinto /etc/${PN}
+ doins config "${FILESDIR}"/logging || die
+
+ # fcgi & wsgi file
+ insinto /usr/share/${PN}
+ doins "${FILESDIR}/radicale.wsgi"
+ use fastcgi && doins "${FILESDIR}/radicale.fcgi"
+}
+
+pkg_postinst() {
+ einfo "Radicale now supports WSGI."
+ einfo "A sample wsgi-script has been put into
+ ${ROOT}usr/share/${PN}."
+ if use fastcgi; then
+ einfo "There you will also find an example fcgi-script."
+ fi
+}
diff --git a/profiles/package.mask b/profiles/package.mask
new file mode 100644
index 0000000..a2e68df
--- /dev/null
+++ b/profiles/package.mask
@@ -0,0 +1 @@
+=app-office/radicale-9999