summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.eu>2020-04-11 21:37:21 +0200
committerRené 'Necoro' Neumann <necoro@necoro.eu>2020-04-11 21:37:21 +0200
commit2fd7f58f9a88a849e00385392338a33365244021 (patch)
tree9e26bfe507f49e798d65a8d89100d33a6f354d5d
parent8239732b866a3bd9fd87720331abe5509e5eba22 (diff)
downloadoverlay-2fd7f58f9a88a849e00385392338a33365244021.tar.gz
overlay-2fd7f58f9a88a849e00385392338a33365244021.tar.bz2
overlay-2fd7f58f9a88a849e00385392338a33365244021.zip
Fix pass ebuild
-rw-r--r--app-admin/pass/pass-9999.ebuild30
1 files changed, 15 insertions, 15 deletions
diff --git a/app-admin/pass/pass-9999.ebuild b/app-admin/pass/pass-9999.ebuild
index 3a316d2..9a600c7 100644
--- a/app-admin/pass/pass-9999.ebuild
+++ b/app-admin/pass/pass-9999.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Id$
EAPI=5
-inherit bash-completion-r1 git-2 elisp-common
+inherit bash-completion-r1 git-r3 elisp-common
-DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely using gpg, pwgen, and git"
-HOMEPAGE="http://www.passwordstore.org/"
-EGIT_REPO_URI="git://git.necoro.eu/others/pass.git"
+DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely"
+HOMEPAGE="https://www.passwordstore.org/"
+EGIT_REPO_URI="https://git.necoro.eu/others/pass.git"
EGIT_BRANCH="necoro"
SLOT="0"
@@ -18,7 +17,7 @@ IUSE="+git X zsh-completion fish-completion emacs dmenu importers elibc_Darwin"
RDEPEND="
app-crypt/gnupg
- app-admin/pwgen
+ media-gfx/qrencode
>=app-text/tree-1.7.0
git? ( dev-vcs/git )
X? ( x11-misc/xclip )
@@ -26,11 +25,9 @@ RDEPEND="
zsh-completion? ( app-shells/gentoo-zsh-completions )
fish-completion? ( app-shells/fish )
dmenu? ( x11-misc/dmenu x11-misc/xdotool )
- emacs? ( virtual/emacs )
+ emacs? ( >=app-editors/emacs-23.1:* )
"
-S="${WORKDIR}/password-store-${PV}"
-
src_prepare() {
use elibc_Darwin || return
# use coreutils'
@@ -46,11 +43,14 @@ src_compile() {
}
src_install() {
- use zsh-completion && export FORCE_ZSHCOMP=1
- use fish-completion && export FORCE_FISHCOMP=1
- emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ BASHCOMPDIR="$(get_bashcompdir)" \
+ WITH_BASHCOMP=yes \
+ WITH_ZSHCOMP=$(usex zsh-completion) \
+ WITH_FISHCOMP=$(usex fish-completion)
use dmenu && dobin contrib/dmenu/passmenu
- newbashcomp src/completion/pass.bash-completion pass
if use emacs; then
elisp-install ${PN} contrib/emacs/*.el
elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
@@ -66,7 +66,7 @@ pkg_postinst() {
if use importers; then
einfo "To import passwords from other password managers, you may use the"
einfo "various importer scripts found in:"
- einfo " ${ROOT}usr/share/${PN}/importers/"
+ einfo " ${EROOT%/}/usr/share/${PN}/importers/"
fi
}