summaryrefslogtreecommitdiff
path: root/dev-python/flask-wtf/flask-wtf-0.9.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-wtf/flask-wtf-0.9.2.ebuild')
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.9.2.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/flask-wtf/flask-wtf-0.9.2.ebuild b/dev-python/flask-wtf/flask-wtf-0.9.2.ebuild
deleted file mode 100644
index eb9b83e..0000000
--- a/dev-python/flask-wtf/flask-wtf-0.9.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-wtf/flask-wtf-0.9.1.ebuild,v 1.1 2013/09/02 04:51:02 patrick Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_3} )
-
-inherit distutils-r1
-
-MY_PN="Flask-WTF"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple integration of Flask and WTForms, including CSRF, file upload and Recaptcha integration."
-HOMEPAGE="http://pythonhosted.org/Flask-WTF/ https://pypi.python.org/pypi/Flask-WTF"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/wtforms-1.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/speaklater[${PYTHON_USEDEP}]
- dev-python/flask-babel[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
-}