summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/i3/Manifest2
-rw-r--r--x11-wm/i3/files/i3-4.12-pango.patch181
-rw-r--r--x11-wm/i3/i3-4.11.ebuild73
-rw-r--r--x11-wm/i3/i3-4.12.ebuild85
4 files changed, 0 insertions, 341 deletions
diff --git a/x11-wm/i3/Manifest b/x11-wm/i3/Manifest
deleted file mode 100644
index ab2c202..0000000
--- a/x11-wm/i3/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST i3-4.11.tar.bz2 972929 SHA256 78ce1e06fbd92fd63765bbe23faa7b8f929c17f99ed623f7abf2e568169d982f SHA512 76d45be9006973dd4093fd21ea1c83742b7977c7698e133ce8f9e7826d97d1631fbe6c3ea4a7eb3d989027f98e12738158e72ec450b0df3dddd28f912ff49a4f WHIRLPOOL f3bff5c0386ad09c5cabb25c7ccb14033f1a7ba3ee19fcc832739cbc61a31f84d3a57418264db4728fbb406c24464a8c87cbfde1e651599a3b63d87eb0af11cb
-DIST i3-4.12.tar.bz2 988084 SHA256 e19e1ce08c2549cba83e083cc768d487202c41760d5c283f67752e791f1d78b4 SHA512 966f62dbd82c6c70d1344cc61f14f154f3f649ce1b5a5b5168f00f50d598582ef26f5bd5496ea62e13213e45b1c7043f6209c94fcbefe2947fec63284445c1f5 WHIRLPOOL 7cf414de6d375029328edc8d824d2542ccae99ddf48eac9a563e81e0e86db5506f45f851d5af755ebfe8514e9afb5f8394d962fb191f4b0ab4268a81b8397395
diff --git a/x11-wm/i3/files/i3-4.12-pango.patch b/x11-wm/i3/files/i3-4.12-pango.patch
deleted file mode 100644
index 6442796..0000000
--- a/x11-wm/i3/files/i3-4.12-pango.patch
+++ /dev/null
@@ -1,181 +0,0 @@
-Fixes builds with without pango/cairo
-
-https://github.com/i3/i3/pull/2243
-https://bugs.gentoo.org/show_bug.cgi?id=576664
-
---- a/include/libi3.h
-+++ b/include/libi3.h
-@@ -20,7 +20,7 @@
- #if PANGO_SUPPORT
- #include <pango/pango.h>
- #endif
--#ifdef CAIRO_SUPPORT
-+#if CAIRO_SUPPORT
- #include <cairo/cairo-xcb.h>
- #endif
-
-@@ -518,7 +518,7 @@ typedef struct placeholder_t {
- */
- char *format_placeholders(char *format, placeholder_t *placeholders, int num);
-
--#ifdef CAIRO_SUPPORT
-+#if CAIRO_SUPPORT
- /* We need to flush cairo surfaces twice to avoid an assertion bug. See #1989
- * and https://bugs.freedesktop.org/show_bug.cgi?id=92455. */
- #define CAIRO_SURFACE_FLUSH(surface) \
-@@ -542,7 +542,7 @@ typedef struct surface_t {
- int width;
- int height;
-
--#ifdef CAIRO_SUPPORT
-+#if CAIRO_SUPPORT
- /* A cairo surface representing the drawable. */
- cairo_surface_t *surface;
-
---- a/libi3/draw_util.c
-+++ b/libi3/draw_util.c
-@@ -11,7 +11,7 @@
- #include <string.h>
- #include <xcb/xcb.h>
- #include <xcb/xcb_aux.h>
--#ifdef CAIRO_SUPPORT
-+#if CAIRO_SUPPORT
- #include <cairo/cairo-xcb.h>
- #endif
-
-@@ -50,7 +50,7 @@ void draw_util_surface_init(xcb_connection_t *conn, surface_t *surface, xcb_draw
- ELOG("Could not create graphical context. Error code: %d. Please report this bug.\n", error->error_code);
- }
-
--#ifdef CAIRO_SUPPORT
-+#if CAIRO_SUPPORT
- surface->surface = cairo_xcb_surface_create(conn, surface->id, surface->visual_type, width, height);
- surface->cr = cairo_create(surface->surface);
- #endif
-@@ -62,7 +62,7 @@ void draw_util_surface_init(xcb_connection_t *conn, surface_t *surface, xcb_draw
- */
- void draw_util_surface_free(xcb_connection_t *conn, surface_t *surface) {
- xcb_free_gc(conn, surface->gc);
--#ifdef CAIRO_SUPPORT
-+#if CAIRO_SUPPORT
- cairo_surface_destroy(surface->surface);
- cairo_destroy(surface->cr);
-
-@@ -81,7 +81,7 @@ void draw_util_surface_free(xcb_connection_t *conn, surface_t *surface) {
- void draw_util_surface_set_size(surface_t *surface, int width, int height) {
- surface->width = width;
- surface->height = height;
--#ifdef CAIRO_SUPPORT
-+#if CAIRO_SUPPORT
- cairo_xcb_surface_set_size(surface->surface, width, height);
- #endif
- }
-@@ -121,7 +121,7 @@ color_t draw_util_hex_to_color(const char *color) {
- static void draw_util_set_source_color(xcb_connection_t *conn, surface_t *surface, color_t color) {
- RETURN_UNLESS_SURFACE_INITIALIZED(surface);
-
--#ifdef CAIRO_SUPPORT
-+#if CAIRO_SUPPORT
- cairo_set_source_rgba(surface->cr, color.red, color.green, color.blue, color.alpha);
- #else
- uint32_t colorpixel = color.colorpixel;
-@@ -139,7 +139,7 @@ static void draw_util_set_source_color(xcb_connection_t *conn, surface_t *surfac
- void draw_util_text(i3String *text, surface_t *surface, color_t fg_color, color_t bg_color, int x, int y, int max_width) {
- RETURN_UNLESS_SURFACE_INITIALIZED(surface);
-
--#ifdef CAIRO_SUPPORT
-+#if CAIRO_SUPPORT
- /* Flush any changes before we draw the text as this might use XCB directly. */
- CAIRO_SURFACE_FLUSH(surface->surface);
- #endif
-@@ -147,7 +147,7 @@ void draw_util_text(i3String *text, surface_t *surface, color_t fg_color, color_
- set_font_colors(surface->gc, fg_color, bg_color);
- draw_text(text, surface->id, surface->gc, surface->visual_type, x, y, max_width);
-
--#ifdef CAIRO_SUPPORT
-+#if CAIRO_SUPPORT
- /* Notify cairo that we (possibly) used another way to draw on the surface. */
- cairo_surface_mark_dirty(surface->surface);
- #endif
-@@ -162,7 +162,7 @@ void draw_util_text(i3String *text, surface_t *surface, color_t fg_color, color_
- void draw_util_rectangle(xcb_connection_t *conn, surface_t *surface, color_t color, double x, double y, double w, double h) {
- RETURN_UNLESS_SURFACE_INITIALIZED(surface);
-
--#ifdef CAIRO_SUPPORT
-+#if CAIRO_SUPPORT
- cairo_save(surface->cr);
-
- /* Using the SOURCE operator will copy both color and alpha information directly
-@@ -194,7 +194,7 @@ void draw_util_rectangle(xcb_connection_t *conn, surface_t *surface, color_t col
- void draw_util_clear_surface(xcb_connection_t *conn, surface_t *surface, color_t color) {
- RETURN_UNLESS_SURFACE_INITIALIZED(surface);
-
--#ifdef CAIRO_SUPPORT
-+#if CAIRO_SUPPORT
- cairo_save(surface->cr);
-
- /* Using the SOURCE operator will copy both color and alpha information directly
-@@ -227,7 +227,7 @@ void draw_util_copy_surface(xcb_connection_t *conn, surface_t *src, surface_t *d
- RETURN_UNLESS_SURFACE_INITIALIZED(src);
- RETURN_UNLESS_SURFACE_INITIALIZED(dest);
-
--#ifdef CAIRO_SUPPORT
-+#if CAIRO_SUPPORT
- cairo_save(dest->cr);
-
- /* Using the SOURCE operator will copy both color and alpha information directly
---- a/libi3/font.c
-+++ b/libi3/font.c
-@@ -397,9 +397,11 @@ static void draw_text_xcb(const xcb_char2b_t *text, size_t text_len, xcb_drawabl
- void draw_text(i3String *text, xcb_drawable_t drawable, xcb_gcontext_t gc,
- xcb_visualtype_t *visual, int x, int y, int max_width) {
- assert(savedFont != NULL);
-+#if PANGO_SUPPORT
- if (visual == NULL) {
- visual = root_visual_type;
- }
-+#endif
-
- switch (savedFont->type) {
- case FONT_TYPE_NONE:
---- a/src/floating.c
-+++ b/src/floating.c
-@@ -11,6 +11,10 @@
- */
- #include "all.h"
-
-+#ifndef MAX
-+#define MAX(x, y) ((x) > (y) ? (x) : (y))
-+#endif
-+
- /*
- * Calculates sum of heights and sum of widths of all currently active outputs
- *
---- a/src/util.c
-+++ b/src/util.c
-@@ -341,10 +341,12 @@ char *pango_escape_markup(char *input) {
- if (!font_is_pango())
- return input;
-
-+#if PANGO_SUPPORT
- char *escaped = g_markup_escape_text(input, -1);
- FREE(input);
-
- return escaped;
-+#endif
- }
-
- /*
---- a/src/x.c
-+++ b/src/x.c
-@@ -12,6 +12,10 @@
- */
- #include "all.h"
-
-+#ifndef MAX
-+#define MAX(x, y) ((x) > (y) ? (x) : (y))
-+#endif
-+
- xcb_window_t ewmh_window;
-
- /* Stores the X11 window ID of the currently focused window */
diff --git a/x11-wm/i3/i3-4.11.ebuild b/x11-wm/i3/i3-4.11.ebuild
deleted file mode 100644
index 17b045c..0000000
--- a/x11-wm/i3/i3-4.11.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="An improved dynamic tiling window manager"
-HOMEPAGE="http://i3wm.org/"
-SRC_URI="http://i3wm.org/downloads/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+pango"
-
-CDEPEND="dev-libs/libev
- dev-libs/libpcre
- >=dev-libs/yajl-2.0.3
- x11-libs/libxcb[xkb]
- x11-libs/libxkbcommon[X]
- x11-libs/startup-notification
- x11-libs/xcb-util
- x11-libs/xcb-util-cursor
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-wm
- pango? (
- >=x11-libs/pango-1.30.0[X]
- >=x11-libs/cairo-1.12.2[X,xcb]
- )"
-DEPEND="${CDEPEND}
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
- dev-lang/perl
- dev-perl/AnyEvent-I3
- dev-perl/JSON-XS"
-
-DOCS=( RELEASE-NOTES-${PV} )
-
-src_prepare() {
- if ! use pango; then
- sed -i common.mk -e '/PANGO/d' || die
- fi
-
- cat <<- EOF > "${T}"/i3wm
- #!/bin/sh
- exec /usr/bin/i3
- EOF
- sed -e 's/FALSE/false/' -i src/handlers.c || die #546444
- epatch_user #471716
-}
-
-src_compile() {
- emake V=1 CC="$(tc-getCC)" AR="$(tc-getAR)"
-}
-
-src_install() {
- default
- dohtml -r docs/*
- doman man/*.1
- exeinto /etc/X11/Sessions
- doexe "${T}"/i3wm
-}
-
-pkg_postinst() {
- einfo "There are several packages that you may find useful with ${PN} and"
- einfo "their usage is suggested by the upstream maintainers, namely:"
- einfo " x11-misc/dmenu"
- einfo " x11-misc/i3status"
- einfo " x11-misc/i3lock"
- einfo "Please refer to their description for additional info."
-}
diff --git a/x11-wm/i3/i3-4.12.ebuild b/x11-wm/i3/i3-4.12.ebuild
deleted file mode 100644
index f3ba5cc..0000000
--- a/x11-wm/i3/i3-4.12.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="An improved dynamic tiling window manager"
-HOMEPAGE="http://i3wm.org/"
-SRC_URI="http://i3wm.org/downloads/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+cairo +pango"
-
-CDEPEND="dev-libs/libev
- dev-libs/libpcre
- >=dev-libs/yajl-2.0.3
- x11-libs/libxcb[xkb]
- x11-libs/libxkbcommon[X]
- x11-libs/startup-notification
- x11-libs/xcb-util
- x11-libs/xcb-util-cursor
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-wm
- cairo? (
- >=x11-libs/cairo-1.14.4[X,xcb]
- )
- pango? (
- >=x11-libs/pango-1.30.0[X]
- >=x11-libs/cairo-1.12.2[X,xcb]
- )"
-DEPEND="${CDEPEND}
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
- dev-lang/perl
- dev-perl/AnyEvent-I3
- dev-perl/JSON-XS"
-
-DOCS=( RELEASE-NOTES-${PV} )
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-pango.patch
-
- if ! use pango; then
- sed -e '/^PANGO_.*pangocairo/d' \
- -e '/PANGO_SUPPORT/ s/1/0/g' \
- -i common.mk || die
- fi
-
- if ! use cairo; then
- sed -e '/CAIRO_SUPPORT/ s/1/0/g' \
- -i common.mk || die
- fi
-
- cat <<- EOF > "${T}"/i3wm
- #!/bin/sh
- exec /usr/bin/i3
- EOF
- sed -e 's/FALSE/false/' -i src/handlers.c || die #546444
- epatch_user #471716
-}
-
-src_compile() {
- emake V=1 CC="$(tc-getCC)" AR="$(tc-getAR)"
-}
-
-src_install() {
- default
- dohtml -r docs/*
- doman man/*.1
- exeinto /etc/X11/Sessions
- doexe "${T}"/i3wm
-}
-
-pkg_postinst() {
- einfo "There are several packages that you may find useful with ${PN} and"
- einfo "their usage is suggested by the upstream maintainers, namely:"
- einfo " x11-misc/dmenu"
- einfo " x11-misc/i3status"
- einfo " x11-misc/i3lock"
- einfo "Please refer to their description for additional info."
-}