summaryrefslogtreecommitdiff
path: root/www-apps/ikiwiki/ikiwiki-3.20100804.ebuild
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2010-08-12 04:31:01 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2010-08-12 04:31:01 +0200
commite79365a048c907f50649bc60d5f215f726a926f1 (patch)
treec357d12a5524e8428fff5648cd618e741cfc197f /www-apps/ikiwiki/ikiwiki-3.20100804.ebuild
parent4a66bb493440dcb4da540686a74d9a3cbbe2e247 (diff)
downloadoverlay-e79365a048c907f50649bc60d5f215f726a926f1.tar.gz
overlay-e79365a048c907f50649bc60d5f215f726a926f1.tar.bz2
overlay-e79365a048c907f50649bc60d5f215f726a926f1.zip
Added ikiwiki
Diffstat (limited to '')
-rw-r--r--www-apps/ikiwiki/ikiwiki-3.20100804.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/www-apps/ikiwiki/ikiwiki-3.20100804.ebuild b/www-apps/ikiwiki/ikiwiki-3.20100804.ebuild
new file mode 100644
index 0000000..f3ba93b
--- /dev/null
+++ b/www-apps/ikiwiki/ikiwiki-3.20100804.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit perl-app
+
+DESCRIPTION="Wiki compiler which converts wiki pages of different format into static HTML pages"
+HOMEPAGE="http://ikiwiki.info"
+SRC_URI="mirror://debian/pool/main/i/ikiwiki/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~amd64"
+IUSE=""
+
+DEPEND="dev-perl/Text-Markdown
+ dev-perl/HTML-Parser
+ dev-perl/HTML-Template
+ dev-perl/HTML-Scrubber
+ dev-perl/CGI-Session
+ >=dev-perl/CGI-FormBuilder-3.05
+ dev-perl/Mail-Sendmail
+ dev-perl/Time-Duration
+ dev-perl/TimeDate
+ dev-perl/RPC-XML
+ dev-perl/XML-Simple
+ dev-perl/XML-Feed
+ dev-perl/File-MimeInfo
+ >=dev-perl/Locale-gettext-1.04"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+SRC_TEST="do"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}