summaryrefslogtreecommitdiff
path: root/dev-python/pmw/pmw-1.3.2.ebuild
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2008-08-01 22:04:55 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2008-08-01 22:04:55 +0200
commita0be121843ac8e22af4d1ab9be30e5d89df924a9 (patch)
tree45d57dcd0ec7694f94de6d552f538519e14de0a6 /dev-python/pmw/pmw-1.3.2.ebuild
parentbd90e437191034059789d128261f6271f9c2f853 (diff)
downloadoverlay-a0be121843ac8e22af4d1ab9be30e5d89df924a9.tar.gz
overlay-a0be121843ac8e22af4d1ab9be30e5d89df924a9.tar.bz2
overlay-a0be121843ac8e22af4d1ab9be30e5d89df924a9.zip
Add pmw
Diffstat (limited to '')
-rw-r--r--dev-python/pmw/pmw-1.3.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pmw/pmw-1.3.2.ebuild b/dev-python/pmw/pmw-1.3.2.ebuild
new file mode 100644
index 0000000..57c3bdb
--- /dev/null
+++ b/dev-python/pmw/pmw-1.3.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-1.2.ebuild,v 1.14 2006/09/27 17:23:17 marienz Exp $
+
+PYTHON_MODNAME="Pmw"
+
+inherit distutils python eutils
+
+DESCRIPTION="A toolkit for building high-level compound widgets in Python using the Tkinter module."
+HOMEPAGE="http://pmw.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pmw/Pmw.${PV}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+LICENSE="MIT"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.1"
+S="${WORKDIR}/Pmw.${PV}/src"
+
+pkg_setup() {
+ # check for Tkinter support in python
+ distutils_python_tkinter
+}
+
+src_unpack() {
+ distutils_src_unpack
+ epatch "${FILESDIR}/${P}-install-no-docs.patch"
+}
+
+src_install() {
+ distutils_src_install
+
+ # remove installed docs from site-packages
+ local docdir=`find . -type d -name doc`
+ dohtml -a html,gif,py "${docdir}"/*
+ dodoc Pmw/README
+}