summaryrefslogtreecommitdiff
path: root/dev-python/pivy/pivy-0.5_alpha592.ebuild
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2010-12-06 21:54:47 +0100
committerRené 'Necoro' Neumann <necoro@necoro.net>2010-12-06 21:54:47 +0100
commit9a5407f7c0e88957e21c76dd28b654b1a60a2346 (patch)
tree159055a08bd4117b891b779b497edcf3e8ab792f /dev-python/pivy/pivy-0.5_alpha592.ebuild
parentbf957f633048df9348374d69884b86396b1f1c2a (diff)
downloadoverlay-9a5407f7c0e88957e21c76dd28b654b1a60a2346.tar.gz
overlay-9a5407f7c0e88957e21c76dd28b654b1a60a2346.tar.bz2
overlay-9a5407f7c0e88957e21c76dd28b654b1a60a2346.zip
fixed pivy
Diffstat (limited to '')
-rw-r--r--dev-python/pivy/pivy-0.5_alpha592.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pivy/pivy-0.5_alpha592.ebuild b/dev-python/pivy/pivy-0.5_alpha592.ebuild
new file mode 100644
index 0000000..d071ea3
--- /dev/null
+++ b/dev-python/pivy/pivy-0.5_alpha592.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_P="Pivy-${PV}"
+
+DESCRIPTION="a Coin binding for Python"
+HOMEPAGE="http://pivy.coin3d.org/"
+SRC_URI="http://omploader.org/vMnl2dA/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/coin
+ >=media-libs/SoQt-1.4.2_alpha"
+
+DEPEND="${RDEPEND}
+ dev-lang/swig"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils_src_prepare
+ python setup.py clean
+}
+