summaryrefslogtreecommitdiff
path: root/dev-python/passlib/passlib-1.6.1.ebuild
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2013-10-16 08:49:44 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2013-10-16 08:49:44 +0200
commit897be156fe95ba9c87f3564a32e385dc27e052cb (patch)
treee2fc0954764a78f8c634e28f7a7533e382a1a993 /dev-python/passlib/passlib-1.6.1.ebuild
parent8016d8e0210901b0321484472b202fc4a2a60c17 (diff)
downloadoverlay-897be156fe95ba9c87f3564a32e385dc27e052cb.tar.gz
overlay-897be156fe95ba9c87f3564a32e385dc27e052cb.tar.bz2
overlay-897be156fe95ba9c87f3564a32e385dc27e052cb.zip
More python packages
Diffstat (limited to '')
-rw-r--r--dev-python/passlib/passlib-1.6.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/passlib/passlib-1.6.1.ebuild b/dev-python/passlib/passlib-1.6.1.ebuild
new file mode 100644
index 0000000..f6f14cb
--- /dev/null
+++ b/dev-python/passlib/passlib-1.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/passlib/passlib-1.6.1.ebuild,v 1.4 2013/09/05 18:46:43 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Password hashing framework supporting over 20 schemes"
+HOMEPAGE="http://code.google.com/p/passlib/"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ nosetests -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dodoc docs/{*.rst,requirements.txt,lib/*.rst}
+}