summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.eu>2019-11-13 23:20:10 +0100
committerRené 'Necoro' Neumann <necoro@necoro.eu>2019-11-13 23:20:10 +0100
commitbb3455df162632cdb68b7f6d4e6a8010871e59f9 (patch)
tree8f2f1475558a08fe50c9a1c66283222b7dc56ef5
parentfee7d67889bf4c2fb713758d9f9e616dd1a57402 (diff)
downloadoverlay-bb3455df162632cdb68b7f6d4e6a8010871e59f9.tar.gz
overlay-bb3455df162632cdb68b7f6d4e6a8010871e59f9.tar.bz2
overlay-bb3455df162632cdb68b7f6d4e6a8010871e59f9.zip
Fixed baikal version
-rw-r--r--www-apps/baikal/Manifest1
-rw-r--r--www-apps/baikal/baikal-0.6.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/www-apps/baikal/Manifest b/www-apps/baikal/Manifest
new file mode 100644
index 0000000..55f90f9
--- /dev/null
+++ b/www-apps/baikal/Manifest
@@ -0,0 +1 @@
+DIST baikal-0.6.1.zip 3437686 BLAKE2B f28d3a63166a73571116759df3662c2b19c2eeeebcd7070574dfc3ee8cb046f2d94fdbc4701669291c1bb2cb2b9b92665726127c852c5457cd285f6ffbcc9b00 SHA512 d88ed9fbe1f934d52fd798165675b90972c47c9e138de61e17a14777590ebad5006c1a414a4e0119eb8fa718e01f2aadb6e1d180e23a51fb33e1b5a3539c9e38
diff --git a/www-apps/baikal/baikal-0.6.1.ebuild b/www-apps/baikal/baikal-0.6.1.ebuild
new file mode 100644
index 0000000..7984fe2
--- /dev/null
+++ b/www-apps/baikal/baikal-0.6.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit webapp
+
+DESCRIPTION="Lightweight CalDAV+CardDAV server"
+HOMEPAGE="http://sabre.io/baikal/"
+SRC_URI="https://github.com/sabre-io/Baikal/releases/download/${PV}/${P}.zip"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~ppc64"
+IUSE="+mysql sqlite"
+REQUIRED_USE="|| ( mysql sqlite )"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=dev-lang/php-6[ctype,filter,json,pdo,session,xml,xmlreader,xmlwriter,mysql?,sqlite?]
+ mysql? ( virtual/mysql )
+ sqlite? ( dev-db/sqlite )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc *.md || die "dodoc failed"
+
+ einfo "Installing web files"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r html/* html/.htaccess Core vendor || die "doins failed"
+
+ einfo "Setting up container for configuration"
+ insinto /etc/${PN}
+
+ einfo "Fixing symlinks"
+ local link target
+ find "${D}${MY_HTDOCSDIR}" -type l | while read link ; do
+ target=$(readlink "${link}")
+ target=${target/..\/Core/Core}
+ rm "${link}" && ln -s "${target}" "${link}"
+ done
+ dosym /etc/${PN} "${MY_HTDOCSDIR}"/Specific
+ dosym . "${MY_HTDOCSDIR}"/html
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+ webapp_src_install
+
+ if has_version www-servers/apache ; then
+ fowners -R apache:apache /etc/${PN}
+ elif has_version www-servers/nginx ; then
+ fowners -R nginx:nginx /etc/${PN}
+ else
+ einfo "/etc/${PN} must be owned by the webserver user for baikal"
+ fi
+}