summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2014-04-29 14:01:25 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2014-04-29 14:01:25 +0200
commitb05aa8c2485a3b1382af43f2ef89fa2e8c70f067 (patch)
tree6521f967903bdd51fe88f0ae0afbebea0037ca0a
parentc09d20d03852f73e030d4d8236f393f91068da0a (diff)
downloadoverlay-b05aa8c2485a3b1382af43f2ef89fa2e8c70f067.tar.gz
overlay-b05aa8c2485a3b1382af43f2ef89fa2e8c70f067.tar.bz2
overlay-b05aa8c2485a3b1382af43f2ef89fa2e8c70f067.zip
Fixed app-admin/pass: Work with dash
-rw-r--r--app-admin/pass/Manifest1
-rw-r--r--app-admin/pass/pass-1.6.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-admin/pass/Manifest b/app-admin/pass/Manifest
new file mode 100644
index 0000000..9df57d0
--- /dev/null
+++ b/app-admin/pass/Manifest
@@ -0,0 +1 @@
+DIST password-store-1.6.1.tar.xz 51096 SHA256 3c154d556c53c76b1a0ccacdc108c34f1fdb4a36fab28a6d2f42f02184290881 SHA512 11ceb1c7c0ab1b691c6d77f4f2402a4e10c68dd1057fadda6b70f1c56f68582edab820a581fb25fc3b8514ee9a2be7cd5438fa594189de705b10239b09df5cb3 WHIRLPOOL 705b173054bfa67d77474e522595a27e279e2c7c2d6f138d150934ae558cdc2a1f95d4420f3aa45e0148bd6443d6e207a526d44f627e9053bb1cf662ed7042f2
diff --git a/app-admin/pass/pass-1.6.1.ebuild b/app-admin/pass/pass-1.6.1.ebuild
new file mode 100644
index 0000000..f5935c3
--- /dev/null
+++ b/app-admin/pass/pass-1.6.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/pass/pass-1.6.1.ebuild,v 1.1 2014/04/24 20:51:25 zx2c4 Exp $
+
+EAPI=4
+
+inherit bash-completion-r1
+
+DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely using gpg, pwgen, and git"
+HOMEPAGE="http://zx2c4.com/projects/password-store/"
+SRC_URI="http://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE="+git X +bash-completion zsh-completion fish-completion dmenu elibc_Darwin"
+
+RDEPEND="
+ app-crypt/gnupg
+ app-admin/pwgen
+ >=app-text/tree-1.7.0
+ git? ( dev-vcs/git )
+ X? ( x11-misc/xclip )
+ elibc_Darwin? ( app-misc/getopt )
+ bash-completion? ( app-shells/bash-completion )
+ zsh-completion? ( app-shells/zsh )
+ fish-completion? ( app-shells/fish )
+ dmenu? ( x11-misc/dmenu )
+"
+
+S="${WORKDIR}/password-store-${PV}"
+
+src_prepare() {
+ sed -i -e 's/==/=/g' Makefile || die
+
+ use elibc_Darwin || return
+ # use coreutils'
+ sed -i -e 's/openssl base64/base64/g' src/platform/darwin.sh || die
+ # host getopt isn't cool, and we aren't brew (rip out brew reference)
+ sed -i -e '/^GETOPT=/s/=.*$/=getopt-long/' src/platform/darwin.sh || die
+ # make sure we can find "mount"
+ sed -i -e 's:mount -t:/sbin/mount -t:' src/platform/darwin.sh || die
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ use bash-completion && export FORCE_BASHCOMP=1
+ use zsh-completion && export FORCE_ZSHCOMP=1
+ use fish-completion && export FORCE_FISHCOMP=1
+ default
+ use dmenu && dobin contrib/dmenu/passmenu
+}