summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.eu>2018-06-10 17:02:39 +0200
committerRené 'Necoro' Neumann <necoro@necoro.eu>2018-06-10 17:02:39 +0200
commit9b8e1ac88265c793629ecfd6f64af5a3553c2cef (patch)
tree7644e7aec9a8e901657ede5f4814a2e0b83c6d04
parent306a5c2032c96ef7718c0c42c38758730499e4bc (diff)
downloadoverlay-9b8e1ac88265c793629ecfd6f64af5a3553c2cef.tar.gz
overlay-9b8e1ac88265c793629ecfd6f64af5a3553c2cef.tar.bz2
overlay-9b8e1ac88265c793629ecfd6f64af5a3553c2cef.zip
stgit-0.18 with version information
-rw-r--r--dev-vcs/stgit/Manifest1
-rw-r--r--dev-vcs/stgit/files/stgit-0.16-man-linkfix.patch11
-rw-r--r--dev-vcs/stgit/stgit-0.18.ebuild88
3 files changed, 100 insertions, 0 deletions
diff --git a/dev-vcs/stgit/Manifest b/dev-vcs/stgit/Manifest
new file mode 100644
index 0000000..28dd255
--- /dev/null
+++ b/dev-vcs/stgit/Manifest
@@ -0,0 +1 @@
+DIST stgit-0.18.tar.gz 235852 BLAKE2B ff35856c1f20a6a611a2faa22ba573b1c33636c9e913322456011c4c5a73c3207ddbd8bfe41cb81b11dffe8db8b89594c1598989ae9fb896cd686594a21d96b2 SHA512 5820cc1a8cdd5183fbe309b4b80568098844ff57934c75a43263b5cfcdac4b64e015abc9ed6a53dd856236d76bd0ebeec31e87561bca0d0d82a6e5ec7a10745f
diff --git a/dev-vcs/stgit/files/stgit-0.16-man-linkfix.patch b/dev-vcs/stgit/files/stgit-0.16-man-linkfix.patch
new file mode 100644
index 0000000..559cf8f
--- /dev/null
+++ b/dev-vcs/stgit/files/stgit-0.16-man-linkfix.patch
@@ -0,0 +1,11 @@
+--- a/Documentation/Makefile 2012-07-08 23:55:38.958779174 +0200
++++ b/Documentation/Makefile 2012-07-08 23:56:42.638010483 +0200
+@@ -72,7 +72,7 @@
+ $(ASCIIDOC) -b xhtml11 -d manpage -f asciidoc.conf $(ASCIIDOC_EXTRA) $<
+
+ %.1 : %.xml
+- xmlto -m callouts.xsl man $<
++ xmlto -m callouts.xsl --stringparam man.base.url.for.relative.links=$(htmldir) man $<
+
+ %.xml : %.txt
+ $(ASCIIDOC) -b docbook -d manpage -f asciidoc.conf $<
diff --git a/dev-vcs/stgit/stgit-0.18.ebuild b/dev-vcs/stgit/stgit-0.18.ebuild
new file mode 100644
index 0000000..9a40c47
--- /dev/null
+++ b/dev-vcs/stgit/stgit-0.18.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="http://www.procode.org/stgit/"
+UPSTREAM_VER=
+[[ -n ${UPSTREAM_VER} ]] && \
+ UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
+
+SRC_URI="https://github.com/ctmarinas/stgit/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${UPSTREAM_PATCHSET_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=">=dev-vcs/git-1.6.3.3"
+
+# NOTE: It seems to be quite important which asciidoc version to use.
+# So keep an eye on it for the future.
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ dev-lang/perl
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.16-man-linkfix.patch"
+)
+
+pkg_setup() {
+ if ! use doc; then
+ echo
+ ewarn "Manpages will not be built and installed."
+ ewarn "Enable the 'doc' useflag, if you want them."
+ echo
+ fi
+}
+
+python_prepare_all() {
+ # Upstream's patchset
+ [[ -n ${UPSTREAM_VER} ]] && \
+ eapply "${WORKDIR}"/patches-upstream
+
+ # this will be a noop, as we are working with a tarball,
+ # but throws git errors --> just get rid of it
+ sed -i -e 's/version\.write_builtin_version()//' setup.py || die
+
+ # write version ourselves
+ if [[ ! -f stgit/builtin_version.py ]]; then
+ echo "version = '${PV}'" > stgit/builtin_version.py
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ # bug 526468
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ doc
+ fi
+}
+
+src_install() {
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ install-doc install-html
+ fi
+
+ distutils-r1_src_install
+
+ newbashcomp stgit-completion.bash 'stg'
+}