summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.eu>2018-12-09 22:45:53 +0100
committerRené 'Necoro' Neumann <necoro@necoro.eu>2018-12-09 22:45:53 +0100
commit8263c426bcdcd01fc36895ef008d5dda611fefd1 (patch)
tree40c45bf22d089e02515bf3d441e25a37fac2b2a4
parent99af4798b07c3fbcc35ad2fc1affc5294914e5f5 (diff)
downloadoverlay-8263c426bcdcd01fc36895ef008d5dda611fefd1.tar.gz
overlay-8263c426bcdcd01fc36895ef008d5dda611fefd1.tar.bz2
overlay-8263c426bcdcd01fc36895ef008d5dda611fefd1.zip
Remove xdotool
-rw-r--r--x11-misc/xdotool/xdotool-9999.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/x11-misc/xdotool/xdotool-9999.ebuild b/x11-misc/xdotool/xdotool-9999.ebuild
deleted file mode 100644
index 8c58e18..0000000
--- a/x11-misc/xdotool/xdotool-9999.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/xdotool-2.20110530.1.ebuild,v 1.10 2014/01/07 16:56:09 vapier Exp $
-
-EAPI=2
-
-EGIT_REPO_URI="https://github.com/jordansissel/xdotool.git"
-
-inherit eutils toolchain-funcs flag-o-matic multilib git-r3
-
-DESCRIPTION="Simulate keyboard input and mouse activity, move and resize windows"
-HOMEPAGE="http://www.semicomplete.com/projects/xdotool/"
-#SRC_URI="http://semicomplete.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-RDEPEND="x11-libs/libXtst
- x11-libs/libX11
- x11-libs/libXinerama
- x11-libs/libxkbcommon"
-DEPEND="${RDEPEND}"
-
-# The test wants to manualy start Xvfb, wont use VirtualX and it tries
-# to run a full gnome-session. For such a tiny application i consider
-# it overkill to rewrite the test scripts to not use it's own X server
-# and add a full blown gnome just to run the tests.
-RESTRICT="test"
-
-src_prepare() {
- sed -i \
- -e "s/installheader post-install$/installheader/" \
- -e 's:\<pkg-config\>:$(PKG_CONFIG):' \
- Makefile || die "sed failed"
-}
-
-src_compile() {
- tc-export CC LD PKG_CONFIG
- default
-}
-
-src_install() {
- emake PREFIX="${D}usr" INSTALLMAN="${D}usr/share/man" INSTALLLIB="${D}usr/$(get_libdir)" install || die
-
- dodoc CHANGELIST README
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/*
- fi
-}