summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2016-08-19 23:07:35 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2016-08-19 23:07:35 +0200
commit408fde59e3d343c48c94311bc3f8e8c0c49f9c7e (patch)
treea983503ab0adec5fbc952b265387b04b814baf35
parent1c39314fbf5d1e81cb94c60155e7a3a83004d82f (diff)
downloadoverlay-408fde59e3d343c48c94311bc3f8e8c0c49f9c7e.tar.gz
overlay-408fde59e3d343c48c94311bc3f8e8c0c49f9c7e.tar.bz2
overlay-408fde59e3d343c48c94311bc3f8e8c0c49f9c7e.zip
Cleanup
-rw-r--r--dev-lang/mlton/Manifest3
-rw-r--r--dev-lang/mlton/mlton-20130715.ebuild62
-rw-r--r--dev-lang/polyml/Manifest1
-rw-r--r--dev-lang/polyml/files/polyml-5.4.1-asm.patch28
-rw-r--r--dev-lang/polyml/files/polyml-5.4.1-configure.patch11
-rw-r--r--dev-lang/polyml/files/polyml-5.5.0-asm.patch10
-rw-r--r--dev-lang/polyml/files/polyml-5.5.0-configure.patch138
-rw-r--r--dev-lang/polyml/files/polyml-5.5.0-x-it-basis.patch21
-rw-r--r--dev-lang/polyml/polyml-5.5.1.ebuild46
-rw-r--r--dev-python/boto/Manifest1
-rw-r--r--dev-python/boto/boto-2.34.0.ebuild25
-rw-r--r--dev-python/flask-babel/Manifest1
-rw-r--r--dev-python/flask-babel/flask-babel-0.9.ebuild44
-rw-r--r--dev-python/flask-wtf/Manifest1
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.9.2.ebuild36
-rw-r--r--dev-python/speaklater/Manifest1
-rw-r--r--dev-python/speaklater/speaklater-1.3-r2.ebuild26
-rw-r--r--net-print/dell-driver/Manifest1
-rw-r--r--net-print/dell-driver/dell-driver-1.00.ebuild102
-rw-r--r--www-apps/hiawatha-monitor/Manifest1
-rw-r--r--www-apps/hiawatha-monitor/hiawatha-monitor-0.6.ebuild38
-rw-r--r--www-servers/hiawatha/Manifest1
-rw-r--r--www-servers/hiawatha/files/hiawatha.initd22
-rw-r--r--www-servers/hiawatha/hiawatha-9.1.1.ebuild69
-rw-r--r--www-servers/hiawatha/metadata.xml14
25 files changed, 0 insertions, 703 deletions
diff --git a/dev-lang/mlton/Manifest b/dev-lang/mlton/Manifest
deleted file mode 100644
index f3bcafd..0000000
--- a/dev-lang/mlton/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST mlton-20130715-1.amd64-linux.tgz 19512324 SHA256 f6f912009b0946b73af88ff5f3e713b6be63b871696e2697ccf1564b56e7d03b SHA512 ac41cf8b2afbba80ed25908b1842348eac1507b2aada103648171db1482358c4176b01d9266dfee053b20fc224653ec58ee9d3265672c02fa3774b7562a319bf WHIRLPOOL 50d265fbfabba1c9ed840a3393bf80f3b86a094a2a4ca5be323fc369bffcc3f5763a7ea3574b0f64be551396d9dea7365d1263629d8b14ef5fefad203544bfbe
-DIST mlton-20130715-1.x86-linux.tgz 18065793 SHA256 92d89627cf760c56d0e9727f328b006341bf5be283fc7d616a6276c26d95b2cf SHA512 13a996952df27420f05f8290920055231156c8982c1cf3c31259d73e0c534258e2aad91596e51809719ffb0b74652aa052d296000f2ab99462714d4ef9a41859 WHIRLPOOL a010aca6ae07c1e824b1fbfabc9c00eca270422783715ed644b864916f604f77115d87130ab5c77f6163d1f24793aee4ca33cf425bde2b680563c03756ba44ec
-DIST mlton-20130715.src.tgz 25606142 SHA256 215857ad11d44f8d94c27f75e74017aa44b2c9703304bcec9e38c20433143d6c SHA512 db273de47dc0059e830332b559918567f5153a0518e067ba71927e3705157f1984d6f6202201cef25aaef29d1a71a637e9a1cb30951e94dbfae4ab1a5e5d40d1 WHIRLPOOL 0c899b0cb17251ca345b73764a86e160ea5bdde5d35f5eb36b1f72202c87dcc251cfb19563744ad7cfe2e10eb76963df79dca023801f858441d5c745046df5be
diff --git a/dev-lang/mlton/mlton-20130715.ebuild b/dev-lang/mlton/mlton-20130715.ebuild
deleted file mode 100644
index 03b30a1..0000000
--- a/dev-lang/mlton/mlton-20130715.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mlton/mlton-20100608.ebuild,v 1.3 2013/04/25 07:27:21 gienah Exp $
-
-inherit base eutils
-
-DESCRIPTION="Standard ML optimizing compiler and libraries"
-BASE_URI="mirror://sourceforge/${PN}"
-SRC_URI="!binary? ( ${BASE_URI}/${P}.src.tgz )
- binary? ( amd64? ( ${BASE_URI}/${P}-1.amd64-linux.tgz )
- x86? ( ${BASE_URI}/${P}-1.x86-linux.tgz ) )"
-
-HOMEPAGE="http://www.mlton.org"
-
-LICENSE="HPND MIT"
-SLOT="0"
-# there is support for ppc64 and ia64, but no
-# binaries are provided and there is no native
-# code generation for these platforms
-KEYWORDS="-* ~amd64 ~x86"
-IUSE="binary doc"
-
-DEPEND="dev-libs/gmp
- doc? ( virtual/latex-base )"
-RDEPEND="dev-libs/gmp"
-
-QA_PRESTRIPPED="binary? (
- usr/bin/mlnlffigen
- usr/bin/mllex
- usr/bin/mlprof
- usr/bin/mlyacc
- usr/lib/mlton/mlton-compile
-)"
-
-src_compile() {
- if use !binary; then
- has_version dev-lang/mlton || die "emerge with binary use flag first"
-
- # Fix location in which to install man pages
- sed -i 's@^MAN_PREFIX_EXTRA :=.*@MAN_PREFIX_EXTRA := /share@' \
- Makefile || die 'sed Makefile failed'
-
- # Does not support parallel make
- emake -j1 all-no-docs || die
- if use doc; then
- export VARTEXFONTS="${T}/fonts"
- emake docs || die "failed to create documentation"
- fi
- fi
-}
-
-src_install() {
- if use binary; then
- # Fix location in which to install man pages
- mv "${WORKDIR}/usr/man" "${WORKDIR}/usr/share" || die "mv man failed"
-
- mv "${WORKDIR}/usr" "${D}" || die "mv failed"
- else
- emake DESTDIR="${D}" install-no-docs || die
- if use doc; then emake DESTDIR="${D}" TDOC="${D}"/usr/share/doc/${P} install-docs || die; fi
- fi
-}
diff --git a/dev-lang/polyml/Manifest b/dev-lang/polyml/Manifest
deleted file mode 100644
index e3bf7d4..0000000
--- a/dev-lang/polyml/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST polyml.5.5.1.tar.gz 5465794 SHA256 cf8009dabc8b5d308d92e201dcd01f17ce14289d30caa8021a87365f4b8e209a SHA512 283954c8bf5599d83ea69916b827b1acae7137fe4add67537026092da2e6f1a89d71d3a394dbba599bbe9e967ded1446f39f4d81afb90301532db6be949f7a6f WHIRLPOOL 5bfeb8dcedcfe9b0a925ed089abc246d70d1269631ee46e9c78b123d461afb80e68640d6c08d77f47e69b0c244e9c7a27750dd7350741911e007f9dbcb2e7f76
diff --git a/dev-lang/polyml/files/polyml-5.4.1-asm.patch b/dev-lang/polyml/files/polyml-5.4.1-asm.patch
deleted file mode 100644
index af8bd8d..0000000
--- a/dev-lang/polyml/files/polyml-5.4.1-asm.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- polyml.5.4.1-orig/libpolyml/x86asm.asm 2011-07-13 00:06:49.000000000 +1000
-+++ polyml.5.4.1/libpolyml/x86asm.asm 2012-01-08 16:00:09.740684843 +1100
-@@ -2714,4 +2714,7 @@
-
-
- ENDIF
-+#if defined(__linux__) && defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
-+#endif
- END
---- polyml.5.4.1-orig/libpolyml/power_assembly.S 2010-04-09 01:49:20.000000000 +1000
-+++ polyml.5.4.1/libpolyml/power_assembly.S 2012-01-08 15:46:35.006200143 +1100
-@@ -1735,3 +1735,6 @@
- dd Mask_assign_byte /* 254 */
- dd Mask_assign_word /* 255 */
-
-+#if defined(__linux__) && defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
-+#endif
---- polyml.5.4.1-orig/libpolyml/sparc_assembly.S 2010-08-13 01:01:36.000000000 +1000
-+++ polyml.5.4.1/libpolyml/sparc_assembly.S 2012-01-08 15:46:12.516642791 +1100
-@@ -1498,3 +1498,6 @@
- .long Mask_assign_byte /* 254 */
- .long Mask_assign_word /* 255 */
-
-+#if defined(__linux__) && defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
-+#endif
diff --git a/dev-lang/polyml/files/polyml-5.4.1-configure.patch b/dev-lang/polyml/files/polyml-5.4.1-configure.patch
deleted file mode 100644
index aaaed02..0000000
--- a/dev-lang/polyml/files/polyml-5.4.1-configure.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- polyml.5.4.1-orig/configure.ac 2010-09-03 21:22:40.000000000 +1000
-+++ polyml.5.4.1/configure.ac 2012-01-09 22:44:04.153668402 +1100
-@@ -321,7 +321,7 @@
- AC_ARG_WITH([portable],
- [AS_HELP_STRING([--with-portable],
- [Build the portable interpreter version of Poly/ML instead of native @<:@default=no@:>@])], [
-- ac_cv_with_portable=yes], [
-+ ac_cv_with_portable="$withval"], [
- ac_cv_with_portable=no])
-
- case "${host_cpu}" in
diff --git a/dev-lang/polyml/files/polyml-5.5.0-asm.patch b/dev-lang/polyml/files/polyml-5.5.0-asm.patch
deleted file mode 100644
index cffa627..0000000
--- a/dev-lang/polyml/files/polyml-5.5.0-asm.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- polyml.5.5-orig/libpolyml/x86asm.asm 2012-05-03 21:07:59.000000000 +1000
-+++ polyml.5.5/libpolyml/x86asm.asm 2012-09-19 17:41:51.767737295 +1000
-@@ -3003,4 +3003,7 @@
- dd Mask_assign_byte ;# 254
- dd Mask_assign_word ;# 255
-
-+#if defined(__linux__) && defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
-+#endif
- END
diff --git a/dev-lang/polyml/files/polyml-5.5.0-configure.patch b/dev-lang/polyml/files/polyml-5.5.0-configure.patch
deleted file mode 100644
index 1a2e114..0000000
--- a/dev-lang/polyml/files/polyml-5.5.0-configure.patch
+++ /dev/null
@@ -1,138 +0,0 @@
-Index: polyml/configure
-===================================================================
---- polyml/configure (revision 1599)
-+++ polyml/configure (revision 1600)
-@@ -20870,10 +20870,8 @@
- # Check whether --with-portable was given.
- if test "${with_portable+set}" = set; then :
- withval=$with_portable;
-- ac_cv_with_portable=yes
- else
--
-- ac_cv_with_portable=no
-+ with_portable=check
- fi
-
-
-@@ -20894,36 +20892,46 @@
-
- $as_echo "#define HOSTARCHITECTURE_SPARC 1" >>confdefs.h
-
-- ac_cv_with_portable=yes
-+ polyarch=interpret
- ;;
- power* | ppc*)
-
- $as_echo "#define HOSTARCHITECTURE_PPC 1" >>confdefs.h
-
-- ac_cv_with_portable=yes
-+ polyarch=interpret
- ;;
- arm*)
-
- $as_echo "#define HOSTARCHITECTURE_ARM 1" >>confdefs.h
-
-- ac_cv_with_portable=yes
-+ polyarch=interpret
- ;;
- ia64*)
-
- $as_echo "#define HOSTARCHITECTURE_IA64 1" >>confdefs.h
-
-- ac_cv_with_portable=yes
-+ polyarch=interpret
- ;;
- *) as_fn_error $? "Poly/ML is not supported for this architecture" "$LINENO" 5 ;;
- esac
-
--# If we have explicitly set --with-portable or we are on a machine without
--# a code-generator set to use the interpreter.
--if test "$ac_cv_with_portable" = "yes"; then
-+# If we explicitly asked to use the interpreter set the architecture to interpreted.
-+if test "x$with_portable" = "xyes" ; then
-+ polyarch=interpret
-+fi
-
-+# If we asked not to use the interpreter check we have native code support.
-+if test "x$with_portable" = "xno" ; then
-+ if test "x$polyarch" = "xinterpret" ; then
-+ as_fn_error $? "--without-portable was given but native code is not supported on this platform" "$LINENO" 5
-+ fi
-+fi
-+
-+# Set the define if this is the interpreter. This is no longer actually used.
-+if test "x$polyarch" = "xinterpret" ; then
-+
- $as_echo "#define INTERPRETED 1" >>confdefs.h
-
-- polyarch=interpret
- fi
-
- # Put this test at the end where it's less likely to be missed.
-Index: polyml/configure.ac
-===================================================================
---- polyml/configure.ac (revision 1599)
-+++ polyml/configure.ac (revision 1600)
-@@ -368,10 +368,10 @@
- # Test the --with-portable option to build the interpreter even if
- # we have a code-generator.
- AC_ARG_WITH([portable],
-- [AS_HELP_STRING([--with-portable],
-- [Build the portable interpreter version of Poly/ML instead of native @<:@default=no@:>@])], [
-- ac_cv_with_portable=yes], [
-- ac_cv_with_portable=no])
-+ [AS_HELP_STRING([--with-portable],
-+ [Build the portable interpreter version of Poly/ML instead of native @<:@default=no@:>@])],
-+ [],
-+ [with_portable=check])
-
- case "${host_cpu}" in
- i[[3456]]86*)
-@@ -384,28 +384,39 @@
- ;;
- sparc*)
- AC_DEFINE([HOSTARCHITECTURE_SPARC], [1], [Define if the host is a Sparc (32 bit)])
-- ac_cv_with_portable=yes
-+ polyarch=interpret
- ;;
- power* | ppc*)
- AC_DEFINE([HOSTARCHITECTURE_PPC], [1], [Define if the host is a Power PC (32 bit)])
-- ac_cv_with_portable=yes
-+ polyarch=interpret
- ;;
- arm*)
- AC_DEFINE([HOSTARCHITECTURE_ARM], [1], [Define if the host is an ARM (32 bit)])
-- ac_cv_with_portable=yes
-+ polyarch=interpret
- ;;
- ia64*)
- AC_DEFINE([HOSTARCHITECTURE_IA64], [1], [Define if the host is Itanium])
-- ac_cv_with_portable=yes
-+ polyarch=interpret
- ;;
- *) AC_MSG_ERROR([Poly/ML is not supported for this architecture]) ;;
- esac
-
--# If we have explicitly set --with-portable or we are on a machine without
--# a code-generator set to use the interpreter.
--if test "$ac_cv_with_portable" = "yes"; then
-+# If we explicitly asked to use the interpreter set the architecture to interpreted.
-+if test "x$with_portable" = "xyes" ; then
-+ polyarch=interpret
-+fi
-+
-+# If we asked not to use the interpreter check we have native code support.
-+if test "x$with_portable" = "xno" ; then
-+ if test "x$polyarch" = "xinterpret" ; then
-+ AC_MSG_ERROR(
-+ [--without-portable was given but native code is not supported on this platform])
-+ fi
-+fi
-+
-+# Set the define if this is the interpreter. This is no longer actually used.
-+if test "x$polyarch" = "xinterpret" ; then
- AC_DEFINE([INTERPRETED], [1], [Define if using the interpreter] )
-- polyarch=interpret
- fi
-
- # Put this test at the end where it's less likely to be missed.
diff --git a/dev-lang/polyml/files/polyml-5.5.0-x-it-basis.patch b/dev-lang/polyml/files/polyml-5.5.0-x-it-basis.patch
deleted file mode 100644
index 2f6ce7b..0000000
--- a/dev-lang/polyml/files/polyml-5.5.0-x-it-basis.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Index: polyml/mlsource/extra/XWindows/ml_bind.ML
-===================================================================
---- polyml/mlsource/extra/XWindows/ml_bind.ML (revision 1600)
-+++ polyml/mlsource/extra/XWindows/ml_bind.ML (revision 1601)
-@@ -2437,7 +2437,7 @@
-
- exception XWindows = XWindows.XWindows;
-
--let
-+local
- open XWindows;
-
- fun printRect _ _ (r:XRectangle) =
-@@ -2447,6 +2447,6 @@
- PolyML.PrettyString ("Rect " ^ PolyML.makestring R)
- end;
- in
-- PolyML.addPrettyPrinter printRect
-+ val () = PolyML.addPrettyPrinter printRect
- end;
-
diff --git a/dev-lang/polyml/polyml-5.5.1.ebuild b/dev-lang/polyml/polyml-5.5.1.ebuild
deleted file mode 100644
index ce344d5..0000000
--- a/dev-lang/polyml/polyml-5.5.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/polyml/polyml-5.5.0.ebuild,v 1.3 2012/12/05 09:49:35 gienah Exp $
-
-EAPI="5"
-
-inherit base autotools versionator
-
-MY_P="${PN}.${PV}"
-
-DESCRIPTION="Poly/ML is a full implementation of Standard ML"
-HOMEPAGE="http://www.polyml.org"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="X elibc_glibc +gmp portable test +threads"
-
-RDEPEND="X? ( x11-libs/motif )
- gmp? ( >=dev-libs/gmp-5 )
- elibc_glibc? ( threads? ( >=sys-libs/glibc-2.13 ) )
- virtual/libffi"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=("${FILESDIR}/${PN}-5.5.0-asm.patch")
-
-src_prepare() {
- base_src_prepare
- eautoreconf
-}
-
-src_configure() {
- econf \
- --with-system-libffi \
- $(use_with X x) \
- $(use_with gmp) \
- $(use_with portable) \
- $(use_with threads)
-}
-
-src_test() {
- emake tests || die "tests failed"
-}
diff --git a/dev-python/boto/Manifest b/dev-python/boto/Manifest
deleted file mode 100644
index b78234c..0000000
--- a/dev-python/boto/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST boto-2.34.0.tar.gz 7302242 SHA256 33baab022ecb803414ad0d6cf4041d010cfc2755ff8acc3bea7b32e77ba98be0 SHA512 5784ab3eb785784fa348f9f572d8e885d297d0e569f503229f0ae3aa66389699c9fe21cd1737e20a9683735dc4e7a765aa2345b013c75a3292ed5995f20699d2 WHIRLPOOL 33c42d3f012410e9f3acead7293073dfea3e97cffa93248d735a76266480ab912935d8300839ef742820f1ed1a093dbf5555c163bd8ee34cf28f09a62a01dff5
diff --git a/dev-python/boto/boto-2.34.0.ebuild b/dev-python/boto/boto-2.34.0.ebuild
deleted file mode 100644
index f11ec30..0000000
--- a/dev-python/boto/boto-2.34.0.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.31.1.ebuild,v 1.1 2014/07/10 23:52:54 radhermit Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Amazon Web Services API"
-HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-# requires Amazon Web Services keys to pass some tests
-RESTRICT="test"
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/flask-babel/Manifest b/dev-python/flask-babel/Manifest
deleted file mode 100644
index ef3b7c2..0000000
--- a/dev-python/flask-babel/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST Flask-Babel-0.9.tar.gz 38881 SHA256 4afd150f360434b00684ba7848358f7961072fd0658a6e81aaa578522699fb4c SHA512 c667c8a532332bb3dd0d694932d17f7f9b2b51f68151767624116853b2e71f2a6b4c47164d17a6f368b67a5cabce97495b18147655fb36aee5034c058d3b9a89 WHIRLPOOL 28309a4a27bfd0fbe30be52613ee9eef5110e3cc38e863c6de200cced579476870e01b92edaeb08fd29e0deabcaa13d14742d188960742d61cf8ba5384476cd1
diff --git a/dev-python/flask-babel/flask-babel-0.9.ebuild b/dev-python/flask-babel/flask-babel-0.9.ebuild
deleted file mode 100644
index 5f48095..0000000
--- a/dev-python/flask-babel/flask-babel-0.9.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-babel/flask-babel-0.9.ebuild,v 1.1 2013/08/10 10:13:03 patrick Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_3} )
-
-inherit distutils-r1
-
-MY_PN="Flask-Babel"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="i18n and l10n support for Flask based on Babel and pytz"
-HOMEPAGE="http://packages.python.org/Flask-Babel/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- dev-python/Babel[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/speaklater-1.3-r2[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.5[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask-wtf/Manifest b/dev-python/flask-wtf/Manifest
deleted file mode 100644
index c8f73b4..0000000
--- a/dev-python/flask-wtf/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST Flask-WTF-0.9.2.tar.gz 245293 SHA256 191a160bfeae0ee1210e9b79258f72eccd3f90b70ef841f59b7a3e3778ea909d SHA512 5c103b1327a5ad5bdff5612a82dc302c7692a7343361b5305f08a90c28f7d481b8b4c39c2af016964172c4fa2e3dfc0590cbfc91e179edc595477444f639a084 WHIRLPOOL 6489c11094f6337b3721ba006be97075cf2418fcfc13e879c5db8f90192e42b04a405816647c64249b2e5a8fc2ba9bb04008d61f12fc9a83fdc8948bbe96da5c
diff --git a/dev-python/flask-wtf/flask-wtf-0.9.2.ebuild b/dev-python/flask-wtf/flask-wtf-0.9.2.ebuild
deleted file mode 100644
index eb9b83e..0000000
--- a/dev-python/flask-wtf/flask-wtf-0.9.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-wtf/flask-wtf-0.9.1.ebuild,v 1.1 2013/09/02 04:51:02 patrick Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_3} )
-
-inherit distutils-r1
-
-MY_PN="Flask-WTF"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple integration of Flask and WTForms, including CSRF, file upload and Recaptcha integration."
-HOMEPAGE="http://pythonhosted.org/Flask-WTF/ https://pypi.python.org/pypi/Flask-WTF"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/wtforms-1.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/speaklater[${PYTHON_USEDEP}]
- dev-python/flask-babel[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
-}
diff --git a/dev-python/speaklater/Manifest b/dev-python/speaklater/Manifest
deleted file mode 100644
index fbf9617..0000000
--- a/dev-python/speaklater/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST speaklater-1.3.tar.gz 3582 SHA256 59fea336d0eed38c1f0bf3181ee1222d0ef45f3a9dd34ebe65e6bfffdd6a65a9 SHA512 ae137d94c497cd4214e230c8906f3ba40e092f248206d37b61de2571567e39e27b7f58bcf2145bd0c81c195c3c5ed03fc0428e0a50c657c5c909ec82719454ef WHIRLPOOL 9e9edc0f6b9943f515eb36a13b038402e4093dfeb302f856858000ce87316508d31aafaf85e67e332b8bdfccec518912d87c61b3e45c930bd22bafc3dae8e1f9
diff --git a/dev-python/speaklater/speaklater-1.3-r2.ebuild b/dev-python/speaklater/speaklater-1.3-r2.ebuild
deleted file mode 100644
index f663866..0000000
--- a/dev-python/speaklater/speaklater-1.3-r2.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/speaklater/speaklater-1.3-r1.ebuild,v 1.2 2013/09/05 18:46:44 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_3} pypy2_0 )
-inherit distutils-r1
-
-DESCRIPTION="Lazy strings for Python"
-HOMEPAGE="https://github.com/mitsuhiko/speaklater"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}/${P}-py3-support.patch" )
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_test() {
- "${PYTHON}" speaklater.py || die "Tests failed under ${EPYTHON}"
-}
diff --git a/net-print/dell-driver/Manifest b/net-print/dell-driver/Manifest
deleted file mode 100644
index 3c56b1c..0000000
--- a/net-print/dell-driver/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST dell-driver-1.00.tar.gz 31754775 SHA256 fee57222aefdef00c641427186d4eee673ffd0789ef74f55ddf03cc068cd96ac SHA512 b0bfe5f630d12761c727ea00650aacc570cb0cac6db76225055d999ee16dc5e8adf971763211811078970348eea0176248485028935e8e5d25d445161700a166 WHIRLPOOL e62a955f831c563b10d8cdbb7b62d7ae8eb539a4b8e86b166338a5020911ce2f95b977807923ef528d92bd20c7b5cb2a31284b584cff2d2d635369df32ba65a7
diff --git a/net-print/dell-driver/dell-driver-1.00.ebuild b/net-print/dell-driver/dell-driver-1.00.ebuild
deleted file mode 100644
index f5e00ce..0000000
--- a/net-print/dell-driver/dell-driver-1.00.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-inherit eutils multilib
-
-DESCRIPTION="Samsung binary unified driver"
-HOMEPAGE="http://www.samsung.com"
-SRC_URI="http://downloads.dell.com/FOLDER01446174M/1/B1265dfw_Linux_v1.00_Driver.tar.gz -> ${P}.tar.gz"
-
-LICENSE="samsung"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-# Parallel support looks ugly, not supported in this ebuild
-IUSE="scanner qt4"
-RESTRICT="mirror strip"
-
-DEPEND=""
-RDEPEND="net-print/cups
- !net-print/splix
- scanner? ( media-gfx/sane-backends )
- qt4? ( dev-qt/qtcore:4 )"
-
-S=${WORKDIR}/cdroot/Linux
-
-src_unpack() {
- # Trailing garbage error, do not die
- tar xozf ${DISTDIR}/${A}
-}
-
-src_prepare() {
- # Fix permissions
- find . -type d -exec chmod 755 '{}' \;
- find . -type f -exec chmod 644 '{}' \;
- find . -type f -name \*.sh -exec chmod 755 '{}' \;
- chmod 755 ./i386/raster*
- chmod 755 ./i386/psto*
- chmod 755 ./i386/mfp
- #chmod 755 ./i386/qt4apps/at_opt/bin/*
- #chmod 755 ./x86_64/at_root/usr/sbin/*
- chmod 755 ./x86_64/raster*
- chmod 755 ./x86_64/psto*
- chmod 755 ./x86_64/mfp
- #chmod 755 ./x86_64/qt4apps/at_opt/bin/*
-}
-
-src_install() {
- SOPT="/opt/Samsung/mfp"
- if [ "${ABI}" == "amd64" ]; then
- SARCH="x86_64"
- SLIBDIR="lib64"
- else
- SARCH="i386"
- SLIBDIR="lib"
- fi
-
- # Printer files
- insinto /usr/libexec/cups/filter
- insopts -m755
- doins ${SARCH}/ps* ${SARCH}/raster*
-
- insinto /usr/libexec/cups/backend
- doins ${SARCH}/mfp
-
- dodir /usr/share/cups/model
- cp -r noarch/at_opt/share/ppd "${D}"/usr/share/cups/model/dell
- gzip "${D}"/usr/share/cups/model/dell/*.ppd
- dolib ${SARCH}/at_root/usr/${SLIBDIR}/libmfp.so.1.0.1
- dolib ${SARCH}/libscmssc.so
-
- if use scanner; then
- insinto /etc/sane.d
- doins noarch/at_root/etc/sane.d/smfp.conf
-
- exeinto /usr/$(get_libdir)/sane/
- doexe ${SARCH}/at_root/usr/${SLIBDIR}/sane/*
- fi
-
- if use qt4; then
- insinto ${SOPT}/share
- doins OEM.ini
- cp -r noarch/at_opt/share/V* noarch/at_opt/share/help \
- noarch/at_opt/share/images noarch/at_opt/share/ui \
- noarch/at_opt/share/utils "${D}"/${SOPT}/share
-
- exeinto ${SOPT}/lib
- doexe ${SARCH}/qt4apps/at_opt/lib/*
- exeinto ${SOPT}/libexec
- doexe ${SARCH}/qt4apps/at_opt/bin/*
- for i in ${SARCH}/qt4apps/at_opt/bin/*; do
- make_wrapper $(basename ${i}) ${SOPT}/libexec/$(basename ${i}) ${SOPT}/libexec ${SOPT}/lib ${SOPT}/bin
- done
- fi
-}
-
-pkg_postinst() {
- if use scanner; then
- elog "You need to add smfp to /etc/sane.d/dll.conf:"
- elog " # echo smfp >> /etc/sane.d/dll.conf"
- fi
-}
diff --git a/www-apps/hiawatha-monitor/Manifest b/www-apps/hiawatha-monitor/Manifest
deleted file mode 100644
index f0338c8..0000000
--- a/www-apps/hiawatha-monitor/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST monitor-0.6.tar.gz 538567 SHA256 8b0627f5fd78c680dd56afb49fe34c96ff252d41582b152c08153a2b6baccf08 SHA512 07731b821ea7fcde83f93af472786d6c4e816544f2e7c8bfa3669f042af19f917a772af0dbfeba786832865d0aa8794af5b248d8d7935a49d7fa7634b6903fad WHIRLPOOL 8d065dbc4e67f7eda047896a94e7303b668da055e9375617c8f4c2f30858673c0ba6fa7e7d3048756637366e940e2b24493c086e452dce3657fc42ac7e20d643
diff --git a/www-apps/hiawatha-monitor/hiawatha-monitor-0.6.ebuild b/www-apps/hiawatha-monitor/hiawatha-monitor-0.6.ebuild
deleted file mode 100644
index b5003d3..0000000
--- a/www-apps/hiawatha-monitor/hiawatha-monitor-0.6.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-MY_P="monitor"
-
-DESCRIPTION="Monitoring application for www-servers/hiawatha"
-HOMEPAGE="http://www.hiawatha-webserver.org/howto/monitor"
-SRC_URI="http://www.hiawatha-webserver.org/files/${MY_P}-${PV}.tar.gz "
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND=""
-RDEPEND="
- www-servers/hiawatha[xslt]
- virtual/cron
- =dev-lang/php-5*[mysql,xsl]
- virtual/mysql"
-
-S=${WORKDIR}/${MY_P}
-
-src_install () {
- default
-
- rm -f ChangeLog README LICENSE
-
- insinto /usr/share/${PN}
- doins -r *
-}
-
-pkg_postinst () {
- elog "Please follow the instructions in /usr/share/doc/${P}/README."
-}
diff --git a/www-servers/hiawatha/Manifest b/www-servers/hiawatha/Manifest
deleted file mode 100644
index 26e0bdb..0000000
--- a/www-servers/hiawatha/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST hiawatha-9.1.1.tar.gz 669052 SHA256 68b1c65eb5f9ab2527875fd0960d3b88aaddb7c79594a405687db2aabac40395 SHA512 3f7632dd80282c68911636b59760c28b63f5673f36c1edff00545fa7b6f6a1f0fa090c4a18c8f5a97d0a46ef90fbaf60843b0c0bec513b4e1e27e672380a3143 WHIRLPOOL 7ed5d483afdeb0c57bad1279a9cd97f63927ca72bec6f0eed3eb326d44aaf092503a12f62cabbbda8a9d1e106ad83102fe7357657f6edc3d2612b127247a87ae
diff --git a/www-servers/hiawatha/files/hiawatha.initd b/www-servers/hiawatha/files/hiawatha.initd
deleted file mode 100644
index 9c04296..0000000
--- a/www-servers/hiawatha/files/hiawatha.initd
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --start --exec "/usr/sbin/hiawatha" \
- --pidfile "/var/run/hiawatha.pid"
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --exec "/usr/sbin/hiawatha" \
- --pidfile "/var/run/hiawatha.pid"
- eend $?
-}
diff --git a/www-servers/hiawatha/hiawatha-9.1.1.ebuild b/www-servers/hiawatha/hiawatha-9.1.1.ebuild
deleted file mode 100644
index 57851ba..0000000
--- a/www-servers/hiawatha/hiawatha-9.1.1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-CMAKE_MIN_VERSION="2.8.4"
-
-inherit cmake-utils
-
-DESCRIPTION="Advanced and secure webserver"
-HOMEPAGE="http://www.hiawatha-webserver.org"
-SRC_URI="http://www.hiawatha-webserver.org/files/${P}.tar.gz"
-
-# NB: version 9.1.1 is a "Gentoo-only" release, which removed the dependency on
-# the bundled PolarSSL
-# --> it is not anounced on the hiawatha homepage
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="debug +cache ipv6 monitor +rewrite rproxy ssl tomahawk +xslt"
-
-DEPEND="
- sys-libs/zlib
- ssl? ( >=net-libs/polarssl-1.2 )
- xslt? ( dev-libs/libxslt
- dev-libs/libxml2 )"
-
-RDEPEND="${DEPEND}"
-PDEPEND="monitor? ( www-apps/hiawatha-monitor )"
-
-pkg_setup() {
- if ! use xslt; then
- ewarn "XSLT has been disabled on your request."
- ewarn "Note that XSLT is needed for directory listings."
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_enable cache CACHE)
- $(cmake-utils_use_enable ipv6 IPV6)
- $(cmake-utils_use_enable debug DEBUG)
- $(cmake-utils_use_enable monitor MONITOR)
- $(cmake-utils_use_enable rewrite TOOLKIT)
- $(cmake-utils_use_enable rproxy RPROXY)
- $(cmake-utils_use_enable ssl SSL)
- $(cmake-utils_use_use ssl SYSTEM_POLARSSL)
- $(cmake-utils_use_enable tomahawk TOMAHAWK)
- $(cmake-utils_use_enable xslt XSLT)
-
- $(cmake_utils_use_enable kernel_linux LOADCHECK)
- -DLOG_DIR:STRING=/var/log/hiawatha
- -DPID_DIR:STRING=/var/run
- -DWEBROOT_DIR:STRING=/var/www/hiawatha
- -DWORK_DIR:STRING=/var/lib/hiawatha
- -DCONFIG_DIR:STRING=/etc/hiawatha
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- newinitd "${FILESDIR}"/hiawatha.initd hiawatha
-
- keepdir /var/{lib,log}/hiawatha
-}
diff --git a/www-servers/hiawatha/metadata.xml b/www-servers/hiawatha/metadata.xml
deleted file mode 100644
index 9a435e8..0000000
--- a/www-servers/hiawatha/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
- <use>
- <flag name='cache'>Enable caching of content.</flag>
- <flag name='monitor'>Pull in www-apps/hiawatha-monitor.</flag>
- <flag name='rewrite'>Enable the rewrite toolkit.</flag>
- <flag name='rproxy'>Allow Hiawatha to serve as a reverse proxy.</flag>
- <flag name='tomahawk'>Enable Tomahawk control server.</flag>
- <flag name='xslt'>Enable XSLT support. This is also needed for directory listings.</flag>
- </use>
-</pkgmetadata>
-