summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2013-09-30 21:42:11 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2013-09-30 21:42:11 +0200
commit2bea0bac753a4c1540807d4de3348afdf117a7c0 (patch)
treee257754adbde2691d577b8e6814568b676501d54
parent6a675a1f85d8587ce014afae4b3cec8defe6c2ff (diff)
downloadoverlay-2bea0bac753a4c1540807d4de3348afdf117a7c0.tar.gz
overlay-2bea0bac753a4c1540807d4de3348afdf117a7c0.tar.bz2
overlay-2bea0bac753a4c1540807d4de3348afdf117a7c0.zip
Flask-restless bump
-rw-r--r--dev-python/flask-restless/Manifest3
-rw-r--r--dev-python/flask-restless/files/docbuild.patch57
-rw-r--r--dev-python/flask-restless/flask-restless-0.12.0.ebuild60
3 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/flask-restless/Manifest b/dev-python/flask-restless/Manifest
new file mode 100644
index 0000000..560065c
--- /dev/null
+++ b/dev-python/flask-restless/Manifest
@@ -0,0 +1,3 @@
+AUX docbuild.patch 2082 SHA256 fa2cdeb8a222a46682729a41cd11c7205b7ae882069ad87d5a74c031316764f4 SHA512 abddba6c5791ed7977187a2e39d7cab234d5316e20ee310029a5dace8792ff9134bde1782966857509c4dd134350d0988fa02b9f00040b95de0caff33a2f539c WHIRLPOOL 01aa14fad9a7e668b78c905f9e0a099ba6acd5e7a70092f561c78818992b5791f28bcdb5e16c16f493c5286dd158c5ed6c3f8604dff68b9a4658adf72ca59522
+DIST flask-restless-0.12.0.tar.gz 502639 SHA256 440e20d97fc75b51339c653f3b741de7fda092ea41d5c3b2c7aea40387fb42e6 SHA512 576ecc36f6eb79c9f27ee146f755de0e0abac8ec46556b4ddc7a4e4dc9b410d31a9998512666c14edf4f4fe7e0d31d29cea28629d3c0a8174ba544aa47d86543 WHIRLPOOL bc205d6ab32210da64549321a8a550029406d62e8be92526c22acf07020b027d05b244c3756f00ce7e187d916ed267bf1cab5d5306bc3cd230e1711ea1b158e3
+EBUILD flask-restless-0.12.0.ebuild 1975 SHA256 9fcce29d4e1e45a73871c55f5ae0b9b4c165c274532c943737f3038218ea8194 SHA512 17c9c4f422cc9056076d0ab4aab2fa1375e578f3a60784e6859e2e183468e1e93bff41e8d0060ed037b87ab07002d8e98e2e66bc6ed34520b5734c6d295b009d WHIRLPOOL 45a153d3ca769ce25a9f61379437f4b9a0156ce62b59cc8c3aa8e86bc22dae138fa30f6600b7db5f589225dbf104e1958ec8011ea864602ab68b9c86353204cc
diff --git a/dev-python/flask-restless/files/docbuild.patch b/dev-python/flask-restless/files/docbuild.patch
new file mode 100644
index 0000000..7e4c655
--- /dev/null
+++ b/dev-python/flask-restless/files/docbuild.patch
@@ -0,0 +1,57 @@
+A number of these settings are simply unworkable in gentoo
+diff -ur flask-restless-0.11.0.orig/docs/conf.py flask-restless-0.11.0/docs/conf.py
+--- docs/conf.py 2013-05-19 01:50:21.000000000 +0800
++++ docs/conf.py 2013-06-10 23:39:05.741199580 +0800
+@@ -99,7 +99,6 @@
+
+ # The name of the Pygments (syntax highlighting) style to use.
+ #pygments_style = 'sphinx'
+-pygments_style = 'flask_theme_support.FlaskyStyle'
+
+ # A list of ignored prefixes for module index sorting.
+ #modindex_common_prefix = []
+@@ -110,14 +110,11 @@
+ # The theme to use for HTML and HTML Help pages. See the documentation for
+ # a list of builtin themes.
+ #html_theme = 'default'
+-html_theme = 'flask'
++#html_theme = 'flask'
+
+ # Theme options are theme-specific and customize the look and feel of a theme
+ # further. For a list of options available for each theme, see the
+ # documentation.
+-html_theme_options = {
+- 'index_logo': 'flask-restless.png'
+-}
+
+ # Add any paths that contain custom themes here, relative to this directory.
+ html_theme_path = ['_themes']
+@@ -253,25 +250,12 @@
+ [u'Jeffrey Finkelstein'], 1)
+ ]
+
+-
+-# Example configuration for intersphinx: refer to the Python standard library.
+-intersphinx_mapping = {'python': ('http://docs.python.org/', None),
+- 'flask': ('http://flask.pocoo.org/docs', None),
+- 'sqlalchemy': ('http://sqlalchemy.org/docs', None),
+- 'flasksqlalchemy':
+- ('http://packages.python.org/Flask-SQLAlchemy',
+- None)}
+-
+ # fall back if theme is not there
+ try:
+- __import__('flask_theme_support')
++ from flaskext import themes
++ themes.html_theme = 'flask'
+ except ImportError, e:
+- print '-' * 74
+- print 'Warning: Flask themes unavailable. Building with default theme'
+- print 'If you want the Flask themes, run this command and build again:'
+- print
+- print ' git submodule update --init'
+- print '-' * 74
++ print 'flask theme unavailable'
+
+ pygments_style = 'tango'
+ html_theme = 'default'
diff --git a/dev-python/flask-restless/flask-restless-0.12.0.ebuild b/dev-python/flask-restless/flask-restless-0.12.0.ebuild
new file mode 100644
index 0000000..28993ae
--- /dev/null
+++ b/dev-python/flask-restless/flask-restless-0.12.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/flask-restless-0.11.0-r1.ebuild,v 1.4 2013/08/25 03:13:48 floppym Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Flask extension for easy ReSTful API generation"
+HOMEPAGE="http://packages.python.org/Flask-Restless/"
+SRC_URI="https://github.com/jfinkels/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( AGPL-3 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/flask-0.7[${PYTHON_USEDEP}]
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil:0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( virtual/python-unittest2[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-httpdomain-1.1.7[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-issuetracker-0.11[${PYTHON_USEDEP}]
+ dev-python/flask-themes[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/docbuild.patch )
+
+python_compile_all() {
+ if use doc; then
+ if ! "${PYTHON}" -c "import flask_restless"; then
+ eerror "flask-restless is not installed. Building of the docs"
+ eerror "requires flask-restless to already be installed."
+ eerror "Firstly emerge without USE=doc, then re-emerge with USE=doc"
+ eerror ""
+ die
+ fi
+ # Changes connect to read issues @ github
+ rm -f docs/changelog.rst
+ einfo "Generating html docs for ${PN}"
+ PYTHONPATH=${PYTHONPATH}"${S}"/docs emake -C docs html \
+ || die "Generating html docs for ${PN} failed"
+ fi
+}
+
+python_test() {
+ nosetests tests/test_*.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}